Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не перезаполняюся исполнители  (Прочитано 1230 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Voyajer

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-27
  • Сайт: 
  • Профессия: Программист 1С
Модуль формы документа:

&НаКлиенте
Процедура БригадаПриИзменении(Элемент)
ДокументОбъект=Объект;
ТрудовоеУчастиеНаКлиенте.ВыполнитьБригадаПриИзменении(ДокументОбъект,стБригада);
КонецПроцедуры

Общий модуль ТрудовоеУчастиеНаКлиенте :

Процедура ВыполнитьБригадаПриИзменении(ДокументОбъект,стБригада) Экспорт
Если ДокументОбъект.Исполнители.Количество()>0 Тогда
Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос("Таблица исполнителей будет перезаполнена. Вы уверены?", Режим, 0);
Если Ответ = КодВозвратаДиалога.Нет Тогда
ДокументОбъект.Бригада=стБригада;
    Возврат;
КонецЕсли;
КонецЕсли;
стБригада=ДокументОбъект.Бригада;
    ТрудовоеУчастиеНаСервере.ДобавитьСостав(ДокументОбъект);
КонецПроцедуры

Общий модуль ТрудовоеУчастиеНаСервере :

&НаСервере
Процедура ДобавитьСостав(ДокументОбъект) Экспорт
ДокументОбъект.Исполнители.Очистить();
Если Не ДокументОбъект.Бригада.Пустая() Тогда
БригадаОбъект=ДокументОбъект.Бригада.ПолучитьОбъект();
ТЧ=БригадаОбъект.Состав;
Для каждого Элемент из ТЧ Цикл
СтрокаТЧ=ДокументОбъект.Исполнители.Добавить();
СтрокаТЧ.Сотрудник=Элемент.ФизЛицо;
КонецЦикла;
КонецЕсли;
КонецПроцедуры

Исполнители не перезаполняются...Проблема, я думаю, при передаче в функцию ДобавитьСостав ДокументОбъект


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ХОРОШЕЕ предположение... :)

а ЧТО говорит отладчик ?? :mellow:
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Параллельный вопрос:
БригадаОбъект=ДокументОбъект.Бригада.ПолучитьОбъект();

Зачем получать объект Бригады?

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 291
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal