Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2018, 05:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите отредактировать регист сведений  (Прочитано 3644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Racurs

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-09-03
  • Компания: КЦ "Раритет"
  • Профессия: Программист 1С
Итак, есть регистр сведений, подчиненный регистратору.
Регистратор является документом, который при открытии просто заполняется из движений, которые сам же и делает. Обратиться к его строкам у меня не получается.
Решил подкорректировать сам регистр.
Пишу:
НЗ = РегистрыСведений.Экономический.СоздатьНаборЗаписей();
НЗ.Отбор.Регистратор.Установить(Док);
НЗ.Прочитать();

Для Каждого Запись Из НЗ Цикл
Если СокрЛП(Запись.Реквизит1) = СокрЛП(Реквизит1) Тогда
Запись.Сумма = 0;
КонецЕсли;
КонецЦикла;

НЗ.Записать();

В результате: никаких ошибок, но и значение Реквизита1 не меняется.
Как все-таки его подправить?
Ставлю задачи, системно интегрирую...


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
У вас в записи Сумма обнуляется...
А где Реквизит1'у что-то присваивается?
В результате чего он будет меняться?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн wise

  • ****
  • Сообщений: 430
  • РЕПУТАЦИЯ: 58
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ОТЛАДЧИКОМ смотри... внешне всё у тебя ПРАВИЛЬНО...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Racurs

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-09-03
  • Компания: КЦ "Раритет"
  • Профессия: Программист 1С
Цитировать
У вас в записи Сумма обнуляется...
Да! Извиняюсь, сумма не меняется! Она должна занулиться в зависимости от условия!

Цитировать
ОТЛАДЧИКОМ смотри... внешне всё у тебя ПРАВИЛЬНО...
Да знать бы куда смотреть! Условие выполняется.
Добавлено: 25 Апр 2014, 09:40

Регистр периодический, периодичность "В пределах секунды".
Ставлю задачи, системно интегрирую...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Разговор слепого с глухим.....

За счет чего у вас должен измениться Реквизит1?!
Приведите хоть один кусок кода, где будет хоть один намек на:
Реквизит1 = <<Что та там>>
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Racurs

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-09-03
  • Компания: КЦ "Раритет"
  • Профессия: Программист 1С
Реквизит1 - не меняется! Он используется только для условия.
Сумма - меняется, она должна занулится!
Ставлю задачи, системно интегрирую...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В результате: никаких ошибок, но и значение Реквизита1 не меняется.
Как все-таки его подправить?

Тогда переведите ЭТО
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Racurs

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-09-03
  • Компания: КЦ "Раритет"
  • Профессия: Программист 1С
Переписываем ТС.
Итак, есть регистр сведений, подчиненный регистратору.
Регистратор является документом, который при открытии просто заполняется из движений, которые сам же и делает. Обратиться к его строкам у меня не получается.
Решил подкорректировать сам регистр.
Пишу:
НЗ = РегистрыСведений.Экономический.СоздатьНаборЗаписей();
НЗ.Отбор.Регистратор.Установить(Док);
НЗ.Прочитать();

Для Каждого Запись Из НЗ Цикл
   Если СокрЛП(Запись.Реквизит1) = СокрЛП(Реквизит1) Тогда
      Запись.Сумма   = 0;
   КонецЕсли;
КонецЦикла;

НЗ.Записать();

В результате: никаких ошибок, но и значение Сумма не меняется.
Как все-таки подправить Сумму?
Добавлено: 25 Апр 2014, 10:20

Регистр периодический
Ставлю задачи, системно интегрирую...

Последний раз редактировалось: Racurs; 25 Апр 2014, 10:20. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Значение Сумма'ы не меняется в регистре или в документе?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Racurs

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-09-03
  • Компания: КЦ "Раритет"
  • Профессия: Программист 1С
Ставлю задачи, системно интегрирую...


 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4395
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5661
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5991
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4586
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2038
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
57 Сообщений
alex0402
29 Сообщений
kiksi
24 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 288
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal