Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Работа с табличным полем  (Прочитано 1636 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн m2rg2rita

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-22
  • Сайт: 
  • Профессия: Ученик 1С
Форма программы представлена во вложении. В табличном поле хаотично размещаются покупатели и товары (размещение происходит вручную пользователем). Все это происходит через закрашивание ячеек.
При нажатии на кнопку "Запуск" закрашенная ячейка с покупателем должна перемещаться в любую соседнюю клетку (из 8 возможных). Клетка, куда произойдет перемещение должна задаваться рандомно.
Есть кусочек кода, который позволяет переместить закрашенную ячейку на одну ячейку вверх. ВОТ ОН:
 	Для Инд = 1 По ЭлементыФормы.ВведитеКоличествострок.Значение-1
Цикл
        Для Каждого Кол Из ТабличноеПоле1.Колонки Цикл
            Если ТабличноеПоле1[Инд][Кол.Имя] = " " Тогда
                ТабличноеПоле1[Инд-1][Кол.Имя] = " ";
                ТабличноеПоле1[Инд][Кол.Имя] = "";
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;



Помогите пожалуйста   :trhregerhg: справиться с поставленной задачей


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 311
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal