Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июн 2018, 01:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает подсчет количества строк табличной части  (Прочитано 11586 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mahaidor

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Платформа 1с8.3.4437. Хочу посчитать количество строк в табличной части документа, с целью проверки её заполненности. Изменения в табличной части происходят только, когда есть строки в ней.

Но при отладке  ругается система , что необнаружен метод КоличествоСтрок()

&НаКлиенте
Процедура ДляТелосложениеПоГрудиПриИзменении()
// Вставить содержимое обработчика.
ТЧ3=Элементы.ТелосложениеПоГруди.ТекущиеДанные;  //расчет телосложения
    Если ТЧ3.КоличествоСтрок()>0 Тогда


Оффлайн mahaidor

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Решил неиспользовать счет строк, нашел альтернативу:
Если (ТЧ3<>Неопределено) 
Тогда ДляДругихПоказателейТелосложенияПриИзменении();
Иначе Предупреждение("Введите плечевую дугу или добавьте новую строку в таблицу+Другие показатели+");
КонецЕсли;
То есть свою задачу я решил. Тема закрыта.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Если ТабличнаяЧасть.Количество() = 0 Тогда
//Одно условие
Иначе
//Второе условие
КонецЕсли;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Здравствуйте. Платформа 1с8.3.4437. Хочу посчитать количество строк в табличной части документа, с целью проверки её заполненности. Изменения в табличной части происходят только, когда есть строки в ней.

Но при отладке  ругается система , что необнаружен метод КоличествоСтрок()

&НаКлиенте
Процедура ДляТелосложениеПоГрудиПриИзменении()
// Вставить содержимое обработчика.
ТЧ3=Элементы.ТелосложениеПоГруди.ТекущиеДанные;  //расчет телосложения
    Если ТЧ3.КоличествоСтрок()>0 Тогда

ТЧ3=Элементы.ТелосложениеПоГруди.ТекущиеДанные;
это вы текущую СТРОКУ получаете, естественно у ней нет смысла количество строк запрашивать.

И это совсем не у элемента формы делается.
Если Объект.ТелосложениеПоГруди.Количество() = 0 Тогда
//ТЧ пустая
Иначе
//ТЧ НЕ пустая
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Здравствуйте. Платформа 1с8.3.4437. Хочу посчитать количество строк в табличной части документа, с целью проверки её заполненности. Изменения в табличной части происходят только, когда есть строки в ней.

Но при отладке  ругается система , что необнаружен метод КоличествоСтрок()

&НаКлиенте
Процедура ДляТелосложениеПоГрудиПриИзменении()
// Вставить содержимое обработчика.
ТЧ3=Элементы.ТелосложениеПоГруди.ТекущиеДанные;  //расчет телосложения
    Если ТЧ3.КоличествоСтрок()>0 Тогда

ТЧ3=Элементы.ТелосложениеПоГруди.ТекущиеДанные;
это вы текущую СТРОКУ получаете, естественно у ней нет смысла количество строк запрашивать.

И это совсем не у элемента формы делается.
Если Объект.ТелосложениеПоГруди.Количество() = 0 Тогда
//ТЧ пустая
Иначе
//ТЧ НЕ пустая
КонецЕсли;
Хорош копировать ui;;t;
:D:D:D

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Хорош копировать ui;;t;
:D:D:D

Каюсь )))
Говорил же себе отступы от края сделать! )))

А если буквоедствовать, то твой код не сработает - у него УП, там надо "Объект." ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Хорош копировать ui;;t;
:D:D:D

Каюсь )))
Говорил же себе отступы от края сделать! )))

А если буквоедствовать, то твой код не сработает - у него УП, там надо "Объект." ;)
Я подумал, что дальше он додумается как действовать:-D

Оффлайн mahaidor

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2396
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3352
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3470
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 800
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 432
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
AIFrame AIFrame
130 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
48 Сообщений
alex0402
44 Сообщений
buketov.av buketov.av
37 Сообщений
ilyay ilyay
36 Сообщений
trialex3
22 Сообщений
magnifico61
21 Сообщений
wise wise
18 Сообщений

* Кто онлайн

  • Точка Гостей: 159
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal