Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Флажок при изменении  (Прочитано 5477 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
Добрый день.
Подскажите, есть две таб. части - Первая и Вторая. В Первой колонки Товар (СправочникСсылка.Товар), Количество (Число) и Выбран (Тип Булево - флажок). Сделать нужно вот что. Когда ставлю флажок в колонке Выбран таб. части Первая, нужно, чтобы эта строка копировалась во Вторую таб. часть с колонками Товар и Количество.

Помогите, пожалуйста! Заранее спасибо!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
СтрокаПервойТЧ = ЭлементыФормы.ПерваяТЧ.ТекущиеДанные;

НоваяСтрока = ВтораяТЧ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаПервойТЧ);

А если снимаешь флажок?
Убирать строку? ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
СтрокаПервойТЧ = ЭлементыФормы.ПерваяТЧ.ТекущиеДанные;

НоваяСтрока = ВтораяТЧ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаПервойТЧ);

А если снимаешь флажок?
Убирать строку? ;)

Да, да, да ) Как очистить, если убрать флажок?
Добавлено: 18 Апр 2014, 13:53

Исправьте меня, пожалуйста. Ошибку выдает.

&НаКлиенте
&НаКлиенте
Процедура УпаковкаВозвратПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Упаковка.ТекущиеДанные;
ВыполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыполнитьНаСервере()
ТекОбъект = РеквизитФормыВЗначение("Объект");
НоваяСтрока = ТекОбъект.Возвратная.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТабличнойЧасти);
ЗначениеВРеквизитФормы(ТекОбъект, "Объект");
КонецПроцедуры

Добавлено: 18 Апр 2014, 13:58

Как я понимаю, это если одинаковые таб. части? Просто я написала не все колонки, т.к. думала, что мне подскажут логику, а там я сама допишу. Так-то у меня табличные части отличаются не только колонкой Выбран (у меня она колонка ВОЗВРАТ).

Последний раз редактировалось: Амалия; 18 Апр 2014, 13:58. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Да, ЗаполнитьЗначенияСвойств() применяется для совпадающих свойств объектов.
В противном случае никто не мешает написать:
НоваяСтрока.Реквизит1 = СтрокаПервойТЧ.Реквизит2;

У вас Управляемое Приложение? Для него пока не придумал. Но точно не так ;)

Если Вам нужна связь между строками двух ТЧ, то надо думать по какому полю эти самые строки связывать:
1. В ТЧ №2 добавить скрытую колонку "НомерСтрокиИзТЧ1"
2. Связывать по колонке "Номенклатура" при условии уникальности значений
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
А по конкретнее можно? Все перепробовала, никак не соображу как правильно.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Так же можете исключить некоторые колонки из ТЧ источника с помощью 4 параметра:
ЗначениеЗаполнить(Приемник, Источник,,"Количество, Сумма");

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А по конкретнее можно? Все перепробовала, никак не соображу как правильно.

"Перепробы" - в студию. А то напоминает "сделайте за меня".
Вы же не из таких, правда? ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
А по конкретнее можно? Все перепробовала, никак не соображу как правильно.

"Перепробы" - в студию. А то напоминает "сделайте за меня".
Вы же не из таких, правда? ;)

Я была бы не против ) Потому что не понимаю как это работает в принципе. Вот вложила картинки табличных частей. Они у меня разные. Я так думаю, что про при нажатии на флажок, строка не скопируется, поэтому добавила кнопку Вести учет возвратной тары. И в нее нужно прописать запрос, если флажок истина, то та строка копируется туда... А сам запрос написать не получается.

Добавлено: 22 Апр 2014, 10:58

Ну вот так я это понимаю:
&НаКлиенте
Процедура ВестиУчетВозвратнойТары(Команда)
ВестиУчет();
КонецПроцедуры

&НаСервере
Процедура ВестиУчет()
//Как я понимаю процедура должна же быть в ТабЧасти Упаковка
    //Если Возврат = Истина Тогда
//вот эта отмеченная строка должна быть скопирована в
//ТабЧасть Возвратная
//КонецЕсли
КонецПроцедуры

Опять же, учетная цена у меня должна сама проставиться и учетная стоимость посчитаться. Ну как посчитать, я знаю, а как проставить цену нет. А так цена идет через документ и регистр по ценам.

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(7)ЗАЧЕМ добавлять и удалять СРАЗУ ? :o
МОЖЕТ при изменении флажка устанавливать переменную ПересчитатьВозвратнуюУпаковку в истину и в процедуре ПриЗаписи ПОЛНОСТЬЮ пересчитывать эту ТЧ. :P
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
(7)ЗАЧЕМ добавлять и удалять СРАЗУ ? :o
МОЖЕТ при изменении флажка устанавливать переменную ПересчитатьВозвратнуюУпаковку в истину и в процедуре ПриЗаписи ПОЛНОСТЬЮ пересчитывать эту ТЧ. :P

Ну может вы подскажете как прописать процедуру?:dfbsdfbsdf:


Теги:
 

Автозаполнение поля табличной части документа при изменении другого поля табличной части документа

Автор dimanpspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 4059
Последний ответ 02 Июн 2015, 15:53
от dimanpsp
Автозаполнение реквизита табличной части документа при изменении одного реквизита

Автор Ирина1109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 21
Просмотров: 4839
Последний ответ 28 Авг 2015, 01:12
от Kironten
В Госдуму поступил проект закона об изменении порядка учета сельскохозяйственной выручки

Автор newsРаздел Новости

Ответов: 0
Просмотров: 539
Последний ответ 21 Май 2014, 10:06
от news
Учет физического показателя при изменении торговой площади в течение отчетного периода

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1248
Последний ответ 22 Май 2014, 19:30
от topics
Гражданам и юридическим лицам не обязательно менять документы при изменении названия улиц

Автор newsРаздел Новости

Ответов: 0
Просмотров: 968
Последний ответ 21 Июл 2015, 15:01
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 322
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal