Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1C 8.3 Запись в регистр сведений - контактная информация email контрагента  (Прочитано 7728 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн veuron

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-19
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день! После перехода с 1С 7.7 Предприятие  -> 1С 8.3 УПП , возникла необходимость добавить в карточки контрагентов email адреса. Адреса хранятся в файле Adresa.DBF. Номер строки в ДБФ файле совпадает с кодом контрагента в 1С 8.3 УПП.
Если я правильно понял, адреса необходимо закидывать в регистр сведений- контактная информация. Никак не вникну как это реализовать в 1С 8.3 УПП, все что "нарыл" в интернете, но с email ничего нету,подскажите как реализовать, вот код:
Процедура ЗагрузитьНажатие(Элемент)
Файл = Новый XBase;
НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Объект.Установить("Контрагент");
НаборЗаписей.Прочитать();
Файл.ОткрытьФайл("D:\adresa.dbf",,Истина); //открываем для чтения
Файл.Первая();
Пока НЕ Файл.ВКонце() Цикл
Адрес = Файл.ПолучитьЗначениеПоля("Adres");
Ном = Файл.НомерЗаписи();
Для каждого Запись из НаборЗаписей Цикл
Если (Запись.Объект.Код = Ном) и (Запись.Вид = Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Адрес электронной почты контрагента для обмена электронными документ")) Тогда
Запись.Представление = Адрес;   
НаборЗаписей.Записать();
КонецЕсли; 
КонецЦикла;
Сообщить(Адрес + " " + Ном);
Файл.Следующая();
КонецЦикла;
Файл.ЗакрытьФайл();
КонецПроцедуры


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так...
Процедура ЗагрузитьНажатие(Элемент)
Файл = Новый XBase;
Файл.ОткрытьФайл("D:\adresa.dbf",,Истина); //открываем для чтения
Файл.Первая();
Пока НЕ Файл.ВКонце() Цикл
Адрес = Файл.ПолучитьЗначениеПоля("Adres");
НайдКонтрагент = Справочники.Контрагенты.НайтиПоКоду("Code");  //код контрагента из базы
Если НайдКонтрагент<>Справочники.Контрагенты.ПустаяСсылка() Тогда
НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Объект.Установить(НайдКонтрагент);
НаборЗаписей.Отбор.Тип.Установить(перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты);
НаборЗаписей.Отбор.Вид.Установить(справочники.ВидыКонтактнойИнформации.АдресЭлектроннойПочтыКонтрагентаДляОбменаДокументами);
НоваяЗапись = НаборЗаписей.Добавить();
НоваяЗапись.Объект = НайдКонтрагент;
НоваяЗапись.Тип = перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты;
НоваяЗапись.Вид = справочники.ВидыКонтактнойИнформации.АдресЭлектроннойПочтыКонтрагентаДляОбменаДокументами;
НоваяЗапись.Значение = Адрес;
НаборЗаписей.Записать();
КонецЦикла;
Файл.Следующая();
КонецЦикла;
Файл.ЗакрытьФайл();
КонецПроцедуры
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Процедура ЗагрузитьНажатие(Элемент)
   Файл = Новый XBase;
   Файл.ОткрытьФайл("D:\adresa.dbf",,Истина); //открываем для чтения
   Файл.Первая();
   Пока НЕ Файл.ВКонце() Цикл
      Адрес = Файл.ПолучитьЗначениеПоля("Adres");
      НайдКонтрагент = Справочники.Контрагенты.НайтиПоКоду("Code");  //код контрагента из базы
      Если НайдКонтрагент<>Справочники.Контрагенты.ПустаяСсылка() Тогда
         НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
         НаборЗаписей.Отбор.Объект.Установить(НайдКонтрагент);
         НаборЗаписей.Отбор.Тип.Установить(перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты);
         НаборЗаписей.Отбор.Вид.Установить(справочники.ВидыКонтактнойИнформации.АдресЭлектроннойПочтыКонтрагентаДляОбменаДокументами);
         НоваяЗапись = НаборЗаписей.Добавить();
         НоваяЗапись.Объект = НайдКонтрагент;
         НоваяЗапись.Тип = перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты;
         НоваяЗапись.Вид = справочники.ВидыКонтактнойИнформации.АдресЭлектроннойПочтыКонтрагентаДляОбменаДокументами;
         НоваяЗапись.Значение = Адрес;
         НаборЗаписей.Записать();
      КонецЕсли;
      Файл.Следующая();
   КонецЦикла;
   Файл.ЗакрытьФайл();
КонецПроцедуры
Тазовод)


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4842
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7736
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9333
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 484
Последний ответ 11 Сен 2017, 10:50
от ilyay
Регистры накопления, Регистры сведений, Документы, Проведение

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 8128
Последний ответ 17 Янв 2014, 21:52
от kot_oo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 206
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal