Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов печатной формы из внешней обработки  (Прочитано 6835 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн thomas.angelo

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-17
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Версия платформы 8.3.4.408, бухгалтерия предприятия 3.0.31.14 типовая конфигурация.
Разрабатываю внешнюю обработку. НаСервере создаю процедуру, затем в ней создаю стандартный документ "Расходный кассовый ордер", заполняю его значениями и провожу:
&НаСервере
Процедура МояПроцедураНаСервере()
//Формируем документ "Расходный кассовый ордер"
НовыйРКО = Документы.РасходныйКассовыйОрдер.СоздатьДокумент();
НовыйРКО.ВидОперации = Перечисления.ВидыОперацийРКО.РасчетыПоКредитамИЗаймам;
НовыйРКО.СчетКасса = ПланыСчетов.Хозрасчетный.КассаОрганизации;
НовыйРКО.СуммаДокумента = ЭтаФорма.ТелоЗайма;                 
НовыйРКО.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");
НовыйРКО.СчетУчетаРасчетовСКонтрагентом =  ПланыСчетов.Хозрасчетный.ПредоставленныеЗаймы;
НовыйРКО.СубконтоДт1 = Контрагент.Ссылка;
НовыйРКО.СубконтоДт2 = Договор.Ссылка;
НовыйРКО.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Выданные ЗАЙМЫ");
НовыйРКО.Выдать = Контрагент.Наименование;
НовыйРКО.ПоДокументу = Контрагент.ДокументУдостоверяющийЛичность;
НовыйРКО.Основание = Договор.Наименование;
НовыйРКО.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры

Теперь необходимо вывести на печать стандартную форму печати документа "Расходный кассовый ордер" (см.рисунок во вложении). Каким образом это можно реализовать? Я так понимаю вызывать печатную форму нужно НаКлиенте в другой процедуре. Но как тогда получить именно тот документ, который был создан и проведен НаСервере?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Нужно ссылку на документ сохранить в реквизит обработки. Он будет доступен и на форме (в контексте сервера естественно).

Если у вас проблема с формированием самой печатной формы, то ее нужно формировать на сервере в виде табличного документа, а уже его передавать на клиент.

Оффлайн thomas.angelo

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-17
  • Сайт: 
  • Профессия: Ученик 1С
Нужно ссылку на документ сохранить в реквизит обработки. Он будет доступен и на форме (в контексте сервера естественно).
А что даёт ссылка на документ, сохраненная в реквизит обработки? Ведь с Клиента я не смогу обратиться к документу по этой ссылке. А наСервере можно обращаться к документу и без этого реквизита на форме.

Цитировать
Если у вас проблема с формированием самой печатной формы, то ее нужно формировать на сервере в виде табличного документа, а уже его передавать на клиент.
Проблема в том, что у документа "Расходный кассовый ордер" отсутствуют макеты. И печатная форма создается путем выполнения вот этой процедуры:
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);

КонецПроцедуры
По идее мне надо выполнить эту процедуру, чтобы получить печатную форму, но как ее выполнить? НаКлиенте я не могу обратиться к объекту документа..
Добавлено: 18 Апр 2014, 06:27

Проблема решена.

&НаКлиенте
Процедура Команда1(Команда)
    Парампампам = Новый Структура("Ключ", ДокументСсылкаНаРКО);
    Форма = ПолучитьФорму("Документ.РасходныйКассовыйОрдер.ФормаОбъекта", Парампампам);
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Форма.Команды.Найти("ГруппаВажныеКомандыКомандаПечати0"), Форма, Форма.Объект);
КонецПроцедуры

Последний раз редактировалось: thomas.angelo; 18 Апр 2014, 06:27. Причина: Объединение сообщений


 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 285
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4813
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3408
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4985
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 582
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 285
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal