Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 12:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов печатной формы из внешней обработки  (Прочитано 7606 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн thomas.angelo

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-17
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Версия платформы 8.3.4.408, бухгалтерия предприятия 3.0.31.14 типовая конфигурация.
Разрабатываю внешнюю обработку. НаСервере создаю процедуру, затем в ней создаю стандартный документ "Расходный кассовый ордер", заполняю его значениями и провожу:
&НаСервере
Процедура МояПроцедураНаСервере()
//Формируем документ "Расходный кассовый ордер"
НовыйРКО = Документы.РасходныйКассовыйОрдер.СоздатьДокумент();
НовыйРКО.ВидОперации = Перечисления.ВидыОперацийРКО.РасчетыПоКредитамИЗаймам;
НовыйРКО.СчетКасса = ПланыСчетов.Хозрасчетный.КассаОрганизации;
НовыйРКО.СуммаДокумента = ЭтаФорма.ТелоЗайма;                 
НовыйРКО.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");
НовыйРКО.СчетУчетаРасчетовСКонтрагентом =  ПланыСчетов.Хозрасчетный.ПредоставленныеЗаймы;
НовыйРКО.СубконтоДт1 = Контрагент.Ссылка;
НовыйРКО.СубконтоДт2 = Договор.Ссылка;
НовыйРКО.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Выданные ЗАЙМЫ");
НовыйРКО.Выдать = Контрагент.Наименование;
НовыйРКО.ПоДокументу = Контрагент.ДокументУдостоверяющийЛичность;
НовыйРКО.Основание = Договор.Наименование;
НовыйРКО.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры

Теперь необходимо вывести на печать стандартную форму печати документа "Расходный кассовый ордер" (см.рисунок во вложении). Каким образом это можно реализовать? Я так понимаю вызывать печатную форму нужно НаКлиенте в другой процедуре. Но как тогда получить именно тот документ, который был создан и проведен НаСервере?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6650
  • РЕПУТАЦИЯ: 787
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Нужно ссылку на документ сохранить в реквизит обработки. Он будет доступен и на форме (в контексте сервера естественно).

Если у вас проблема с формированием самой печатной формы, то ее нужно формировать на сервере в виде табличного документа, а уже его передавать на клиент.

Оффлайн thomas.angelo

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-17
  • Сайт: 
  • Профессия: Ученик 1С
Нужно ссылку на документ сохранить в реквизит обработки. Он будет доступен и на форме (в контексте сервера естественно).
А что даёт ссылка на документ, сохраненная в реквизит обработки? Ведь с Клиента я не смогу обратиться к документу по этой ссылке. А наСервере можно обращаться к документу и без этого реквизита на форме.

Цитировать
Если у вас проблема с формированием самой печатной формы, то ее нужно формировать на сервере в виде табличного документа, а уже его передавать на клиент.
Проблема в том, что у документа "Расходный кассовый ордер" отсутствуют макеты. И печатная форма создается путем выполнения вот этой процедуры:
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);

КонецПроцедуры
По идее мне надо выполнить эту процедуру, чтобы получить печатную форму, но как ее выполнить? НаКлиенте я не могу обратиться к объекту документа..
Добавлено: 18 Апр 2014, 06:27

Проблема решена.

&НаКлиенте
Процедура Команда1(Команда)
    Парампампам = Новый Структура("Ключ", ДокументСсылкаНаРКО);
    Форма = ПолучитьФорму("Документ.РасходныйКассовыйОрдер.ФормаОбъекта", Парампампам);
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Форма.Команды.Найти("ГруппаВажныеКомандыКомандаПечати0"), Форма, Форма.Объект);
КонецПроцедуры

Последний раз редактировалось: thomas.angelo; 18 Апр 2014, 06:27. Причина: Объединение сообщений


 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 638
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 158
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5261
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3804
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5801
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal