Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июн 2018, 07:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переделка внешнего обработчика для УПП 1с 8.2  (Прочитано 1688 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн fat001

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-02
  • Сайт: 
  • Профессия: Программист 1С
Приветствую имеется внешняя обработка для УНФ позволяющая создать несколько заказов на производство на основании заказов от покупателя. Писалась и тестировалась для релиза 1.3.2.5 как ее переделать для УПП 8.2 код модуля прилагаю.


Функция СведенияОВнешнейОбработке() Экспорт
   
   РегистрационныеДанные = Новый Структура;
   РегистрационныеДанные.Вставить("Наименование", "Создание заказов на производство");
   РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
   РегистрационныеДанные.Вставить("Версия", "1.0");
   РегистрационныеДанные.Вставить("Вид", "СозданиеСвязанныхОбъектов");
   РегистрационныеДанные.Вставить("Информация", "Создание заказов на производство на основании заказа покупателя");
   
   /////////////// команды /////////////////////////
   
   тзКоманд = Новый ТаблицаЗначений;
   тзКоманд.Колонки.Добавить("Идентификатор");
   тзКоманд.Колонки.Добавить("Представление");
   тзКоманд.Колонки.Добавить("Модификатор");
   тзКоманд.Колонки.Добавить("ПоказыватьОповещение");
   тзКоманд.Колонки.Добавить("Использование");
   
   строкаКоманды = тзКоманд.Добавить();
   строкаКоманды.Идентификатор = "Создать";
   строкаКоманды.Представление = "Создать заказы на производство";
   строкаКоманды.ПоказыватьОповещение = Истина;
   
   строкаКоманды.Использование = "ВызовКлиентскогоМетода";
                                    
   РегистрационныеДанные.Вставить("Команды", тзКоманд);
   
   МассивНазначений = Новый Массив;
   МассивНазначений.Добавить("Документ.ЗаказПокупателя");
   РегистрационныеДанные.Вставить("Назначение", МассивНазначений);
      
   Возврат РегистрационныеДанные;
   
КонецФункции

Процедура ПолучитьДанныеПоЗаказам(ОбъектыНазначения,Заказы) Экспорт
   
   Заказы.Очистить();
   
   Запрос = Новый Запрос;
   
   Запрос.УстановитьПараметр("ОбъектыНазначения",ОбъектыНазначения);
               
   Запрос.Текст = "            
       |ВЫБРАТЬ РАЗРЕШЕННЫЕ
      |
      |   ВЫБОР
      |      КОГДА Константы.ФункциональнаяОпцияРезервированиеЗапасов
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка
      |      ИНАЧЕ ЗНАЧЕНИЕ(Документ.ЗаказПокупателя.ПустаяСсылка)
      |   КОНЕЦ КАК ЗаказПокупателя,
      |
      |   ЗаказПокупателяЗапасы.Ссылка.Организация КАК Организация,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи
      |      ИНАЧЕ ЗНАЧЕНИЕ(Справочник.СтруктурныеЕдиницы.ПустаяСсылка)
      |   КОНЕЦ КАК СтруктурнаяЕдиница,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение)
      |            И ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаРезерв = ЗНАЧЕНИЕ(Справочник.СтруктурныеЕдиницы.ПустаяСсылка)
      |            И (ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Склад)
      |               ИЛИ ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение))
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения
      |      ИНАЧЕ ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаРезерв
      |   КОНЕЦ КАК СтруктурнаяЕдиницаРезерв,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЗаказПокупателя.ЗаказНаряд)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.Финиш
      |      ИНАЧЕ ЗаказПокупателяЗапасы.ДатаОтгрузки
      |   КОНЕЦ КАК Финиш,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЗаказПокупателя.ЗаказНаряд)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.Старт
      |      ИНАЧЕ ДОБАВИТЬКДАТЕ(ЗаказПокупателяЗапасы.ДатаОтгрузки, ДЕНЬ, -ЗаказПокупателяЗапасы.Номенклатура.СрокПополнения)
      |   КОНЕЦ КАК Старт,
      |
      |   ЗаказПокупателяЗапасы.Номенклатура     КАК Номенклатура,
      |   ЗаказПокупателяЗапасы.Характеристика   КАК Характеристика,
      |   ЗаказПокупателяЗапасы.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
      |   ЗаказПокупателяЗапасы.Количество       КАК Количество,
      |   ЗаказПокупателяЗапасы.Количество       КАК Резерв,
      |   ЗаказПокупателяЗапасы.Спецификация     КАК Спецификация
      |ИЗ
      |   Документ.ЗаказПокупателя.Запасы КАК ЗаказПокупателяЗапасы,
      |   Константы КАК Константы
      |ГДЕ
      |   ЗаказПокупателяЗапасы.Ссылка В (&ОбъектыНазначения)
      |";
   
   Рез = Запрос.Выполнить();
   
   Если Рез.Пустой() Тогда
      Возврат;
   Иначе
      Заказы =  Рез.Выгрузить();
   КонецЕсли;   
   
КонецПроцедуры   


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
1) Проще будет прикрепить саму обработку!
Тазовод)

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Для начала нужно посмотреть в обработке какие функции и процедуры используются, если нет обращения к процедурам конкретно из самой конфигурации, то продолжаем копать дальше, смотрим какие обращения к объектам и к метаданным есть, правим их на УПП объекты и метаданные, так же смотрим запрос и правим поля которые называются по другому или не существуют.

Оффлайн fat001

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-02
  • Сайт: 
  • Профессия: Программист 1С
Для начала нужно посмотреть в обработке какие функции и процедуры используются, если нет обращения к процедурам конкретно из самой конфигурации, то продолжаем копать дальше, смотрим какие обращения к объектам и к метаданным есть, правим их на УПП объекты и метаданные, так же смотрим запрос и правим поля которые называются по другому или не существуют.
Можно по подробние я в этом деле новечек ?

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Можно по подробние я в этом деле новечек ?
Вообще-то программистам за такие дела очень хорошие деньги платят.:) Именно за переделки и доделки.
Изучайте особенности программирования в 1С и будет вам счастье.


Теги:
 

Не открывается форма внешнего приложения из другой формы этого же приложения

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1258
Последний ответ 16 Окт 2015, 09:57
от ktu78
Создание отбора отдельным элементом на форме внешнего отчета через настройки скд без программирования.

Автор MeatCrashРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1063
Последний ответ 14 Янв 2017, 10:14
от MeatCrash
Перенесено: Закрытие доступа к базе 1с лоакльной сети из внешнего мира - Интернет

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 580
Последний ответ 16 Июл 2016, 09:15
от cska-fanat-kz
Помогите нубу. Как можно выполнить загрузку справочника в 1С 8 из внешнего файла

Автор AndrewTheFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 18
Просмотров: 4831
Последний ответ 27 Окт 2014, 15:53
от AndrewTheF
Ценовые группы, категори и загрузка данных внешнего источника

Автор Bask25Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 344
Последний ответ 22 Мар 2017, 09:28
от Bask25

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
AIFrame AIFrame
130 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
48 Сообщений
alex0402
44 Сообщений
buketov.av buketov.av
37 Сообщений
ilyay ilyay
36 Сообщений
trialex3
22 Сообщений
magnifico61
21 Сообщений
wise wise
18 Сообщений

* Кто онлайн

  • Точка Гостей: 315
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal