Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 15:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: уникальность наименования  (Прочитано 1318 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн malvina_l

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-08
  • Сайт: 
  • Профессия: Программист 1С
Помогите пожалуйста!!!!
Есть документ, в документе есть табличная часть с полем серии,серии-это спарвочник "СЕрии" , делаю в документе в обработке проведения на уникальность этого поля не работает никак!!!
            ТЧ=ЭтотОбъект.Товары.Выгрузить();
      Для каждого ТекСтрока из ТЧ цикл

        Запрос=Новый Запрос;
      Запрос.Текст="ВЫБРАТЬ
                   |   СерииНоменклатуры.СерияНоменклатуры,
                   |   СерииНоменклатуры.СерияНоменклатуры.Наименование,
                   |   СерииНоменклатуры.СерияНоменклатуры.Ссылка
                   |ИЗ
                   |   Справочник.СерииНоменклатуры КАК СерииНоменклатуры
                   |ГДЕ
                   |   СерииНоменклатуры.СерияНоменклатуры.Наименование <> &СерияНоменклатуры";
                |   И СерииНоменклатуры.СерияНоменклатуры= &Серия";
               
   Запрос.УстановитьПараметр("СерияНоменклатуры",ТекСтрока.СерияНоменклатуры.Наименование);
   Запрос.УстановитьПараметр("Серия",ТекСтрока.справочник);    
   Если НЕ Запрос.Выполнить().Пустой() Тогда
        Сообщить("СерияНоменклатуры " + ТекСтрока.СерияНоменклатуры + " не уникально");
        Отказ = Истина;
    КонецЕсли;
КонецЦикла;




Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)
{
Запрос.УстановитьПараметр("СерияНоменклатуры",ТекСтрока.СерияНоменклатуры.Наименование);
Запрос.УстановитьПараметр("Серия",ТекСтрока.справочник);
}
НАВЕРНОЕ, здесь ОШИБКА.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Проверяйте лучше примерно в таком ключе:
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПоступлениеТоваровУслугТовары.Номенклатура КАК Номенклатура,
| СУММА(1) КАК КоличествоТоваров
|ПОМЕСТИТЬ ВТ
|ИЗ
| Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
|ГДЕ
| ПоступлениеТоваровУслугТовары.Ссылка = &СсылкаНаДокумент
|
|СГРУППИРОВАТЬ ПО
| ПоступлениеТоваровУслугТовары.Номенклатура
|
|ИНДЕКСИРОВАТЬ ПО
| Номенклатура
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ВТ.Номенклатура,
| ВТ.КоличествоТоваров
|ИЗ
| ВТ КАК ВТ
|ГДЕ
| ВТ.КоличествоТоваров > 1";

Запрос.УстановитьПараметр("СсылкаНаДокумент", СсылкаНаДокумент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// Здесь ругаемся на дубли
КонецЦикла;

То есть работайте только с ТЧ, а вы делаете зачем-то N запросов к справочнику.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

УНФ планировщик выдает на план-графике вместо контрагентов <Точка 1>, <Точка 2> и т.д. Как можно отобразить наименования контрагентов вместо точек?

Автор olesya9393Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 484
Последний ответ 09 Янв 2017, 12:55
от olesya9393
Печать "Поля ввода" вместо наименования товара

Автор AXTAZYРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1623
Последний ответ 14 Фев 2016, 14:24
от AXTAZY
1c 8.3 розница базовая. При поиске в РМК по штрихкоду в конце наименования добавляются лишние символы

Автор Olesya_TРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4187
Последний ответ 08 Апр 2016, 17:51
от Rasty
Изменение наименования документа в отчёте движений на СКД в зависимости от условия

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 509
Последний ответ 12 Апр 2016, 03:31
от Golickoff
Ограничение на создание и изменение наименования элементов в справочнике

Автор a.nikulnikovaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 1052
Последний ответ 01 Июл 2016, 05:18
от a.nikulnikova

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal