Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает функция ПоместитьФайл  (Прочитано 3104 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mahaidor

  • **
  • Сообщений: 68
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Работаю в 1с 8.3.4437
Решил реализовать загрузку изображений в элементы справочников через общий модуль, так как есть несколько справочников для которых требуется загрузка рисунков. Алгоритм в модуле формы справочника работает, а если его реализовывать в общем модуле, то 1с ругается типа функция ПоместитьФайл неопределена. Ниже код:
        Процедура ОбработкаСозданияФормыНаСервере (Рисунок,ФайлРисунка,РазмерРисунка) Экспорт
      Рисунок = ПолучитьНавигационнуюСсылку(ФайлРисунка, "Файл");
              РазмерРисунка = РазмерКартинки.АвтоРазмер;
         КонецПроцедуры
--------------------------------------------------
Процедура ЗагрузитьКартинку(Рисунок,ФайлРисунка) Экспорт
ИмяФайла = "";
        ПутьФайла = "";
//Вызываем Диалоговое окно и помещаем файл изображения из локальной файловой системы во временное хранилище
Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда
 //в строковый реквизит "Рисунок" нашей формы сохраняем ссылку на изображение во временном хранилище
Рисунок = ПутьФайла;
//для создания нового элемента в Справочнике Файлы и записи картинки в его реквизите Файл
//переходим на сервер с помощью вызова серверной процедуры
УстановитьКартинку(Рисунок,ФайлРисунка);
КонецЕсли;
//условие ЕСЛИ нужно для того, чтобы если пользователь отказался от выбора файла
//мы не вызывали серверную процедуру УстановитьКартинку()
КонецПроцедуры
----------------------------------------------------------------------------------
Процедура УстановитьКартинку(Рисунок,ФайлРисунка) Экспорт
НовыйФайлКартинки = Справочники.Файлы.СоздатьЭлемент();
//в реквизит СправочникаФайлы Файл помещаем выбранную ранее Картинку
НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Рисунок));
Рисунок = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить());
//записываем новый элемент справочника Файлы
НовыйФайлКартинки.Записать();

//устанавливаем значение реквизита Картинка Справочника Сотрудники
ФайлРисунка = НовыйФайлКартинки.Ссылка;
КонецПроцедуры


Оффлайн mahaidor

  • **
  • Сообщений: 68
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Ошибку эту решил, добавив соответствующие директивы: &НаКлиенте и &НаСервере

Но теперь ругается на Процедуру УстановитьКартинку, типа неопределена.
Добавлено: 13 Апр 2014, 13:24

Убрал директиву перед процедурой УстановитьКартинку, ошибка исправилась, но теперь 1с ругается, что не может найти конструктор ХранилищаЗначения
Добавлено: 13 Апр 2014, 14:14

Чудно, это в режиме отладки не видит конструктор хранилищазначения, а если напрямую запустить режим пользователя, то все у меня работает

Последний раз редактировалось: mahaidor; 13 Апр 2014, 14:14. Причина: Объединение сообщений


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 295
Последний ответ 21 Сен 2017, 10:33
от Insider
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4102
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 126
Последний ответ 15 Дек 2017, 14:36
от alex0402
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3682
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3769
Последний ответ 20 Июн 2011, 11:14
от Zvezo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal