Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 19:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение .Документа данными  (Прочитано 1525 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн qwedor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 1С
Есть документ "Реализация", в нем табл. часть - "Товары".
в табл. части товары есть такое:
номенклатура, цена,  количество,  УчетноеКоличество. ... 


при формировании налоговой накладной в документ "Налоговая накладная" передаются данные из табл.части "Товары"  таим образом:
(в модуле документа Реализация)
Документ = Документы.НалоговаяНакладная.СоздатьДокумент();
.....
Документ.СкопироватьТовары(ЭтотОбъект.Ссылка);


оно все работает. проблем - 0.
При формировании налоговой В Поле "Количество" - оно берет данные из ДокументРеализации.Товары.Количество

а надо подменить эти данные из ДокументРеализации.Товары.УчетноеКоличество


не знаю понятно ли я объяснил. но дума знающие люди поймут :)




Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Тут нужно переделать заполнение, т.е. придется переберать всю ТЧ реализации и вставлять построчно в другую табличную часть.
Типа того:
ДокументРеализация = ..............
Документ = Документ.НалоговаяНакладная.СоздатьДокумент();
Для Каждого СтрокаТовары Из ДокументРеализация .Товары Цикл
    НоваяСтрока = Документ.Товары.Добавить();
    ЗаполнитьЗначениеСвойств(СтрокаТовары, НоваяСтрока);
    НоваяСтрока.Количество = СтрокаТовары.УчетноеКоличество;
КонецЦикла;

Оффлайн qwedor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 1С
Спасибо, работает.  но сделал немного по другому:
Для Каждого СтрокаТовары Из  ЭтотОбъект.Ссылка.Товары Цикл
КоличествоЗачетное = СтрокаТовары.КоличествоЗачетное;
КонецЦикла;

......

Документ.СкопироватьТовары(ЭтотОбъект.Ссылка);
Для Каждого СтрокаТабличнойЧасти Из Документ.Товары Цикл
СтрокаТабличнойЧасти.Количество = КоличествоЗачетное;
КонецЦикла;


Но вылезла другая проблема. если товаров больше 1-го и КоличествоЗачетное у всех разное, в результате получаю У всех товаров "Количество", в налоговой накладной  - последнее КоличествоЗачетное в документе.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Ничего не понял))

Оффлайн qwedor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 1С
Ничего не понял))
уже решил задачу :)

Для Каждого СтрокаТовары Из  Товары Цикл			
Документ.Товары[Товары.Индекс(СтрокаТовары)].Количество = СтрокаТовары.КоличествоЗачетное;

КонецЦикла;



Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4484
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7759
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4790
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8558
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7349
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
63 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 259
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal