Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 8.2 пустое значение документа  (Прочитано 6674 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
В документе есть Реквизит с типом ДокументСсылка.
Как проверить поле на пустое значение?
 
 


Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
ДокументСсылка = Документы.НаименованиеДокумента.ПустаяСсылка();

Оффлайн bunzuk1991

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 4
  • КПД: 18%
  • Регистрация: 2011-11-26
  • Сайт: 
  • Профессия: Бухгалтер
Если ЗначениеЗаполнено(ДокументСсылка) Тогда
сдесь описуеш если Ссылка заполнена

Иначе


КонецЕсли;

ИЛИ

Если ДокументСсылка = Документы.Документ.ПустаяСсылка() Тогда
сдесь описуеш если Ссылка не заполнена
Иначе

КонецЕсли;

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Кстати ЗначениеЗаполнено() - намного дольше выполняется ибо простое сравнение с пустойссылкой(), поэтому разработчики 1С рекомендуют использовать значение только в исключительных случаях. :befhbt:

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Если ЗначениеЗаполнено(ДокументСсылка) Тогда
сдесь описуеш если Ссылка заполнена

Иначе


КонецЕсли;

ИЛИ

Если ДокументСсылка = Документы.Документ.ПустаяСсылка() Тогда
сдесь описуеш если Ссылка не заполнена
Иначе

КонецЕсли;
Спасибо...:ooifh:
Использовала первое решение
Вот так получилось, если ссылка не заполнена

Если НЕ ЗначениеЗаполнено(ДокументСсылка) Тогда

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Если ЗначениеЗаполнено(ДокументСсылка) Тогда
сдесь описуеш если Ссылка заполнена

Иначе


КонецЕсли;

ИЛИ

Если ДокументСсылка = Документы.Документ.ПустаяСсылка() Тогда
сдесь описуеш если Ссылка не заполнена
Иначе

КонецЕсли;
Спасибо...:ooifh:
Использовала первое решение
Вот так получилось, если ссылка не заполнена

Если НЕ ЗначениеЗаполнено(ДокументСсылка) Тогда
Лучше сразу приучайся как я сказал;)
Если ДокументСсылка = Документы.Документ.ПустаяСсылка() Тогда
//Делаем это
Иначе
//Делаем другое
КонецЕсли;

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
ДокументСсылка = Документы.НаименованиеДокумента.ПустаяСсылка();
так почему-то не получается...

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
ДокументСсылка = Документы.НаименованиеДокумента.ПустаяСсылка();
так почему-то не получается...
Что говорит?

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
ДокументСсылка = Документы.НаименованиеДокумента.ПустаяСсылка();
так почему-то не получается...
Что говорит?
ничего не говорит, просто не выполняется...
я это пишу в процедуре перед открытием документа
т.е. если ДокументСсылка не заполнена, тогда Отказ=Истина
Чтобы нельзя было этот документ сделать по кнопке Добавить, а только вводом на основании другого, где этот реквизит заполняется автоматически...
Добавлено: 11 Апр 2014, 15:58

ДокументСсылка = Документы.НаименованиеДокумента.ПустаяСсылка();

Так работает, если тип реквизита, не ДокументСсылка,а документСсылка.НаименованиеДокумента
Может я неправильно изначально тип присвоила?! Мне нужно чтобы это была ссылка на 2 вида документа.
Мне кажется, что в 8.1 можно было конкретно для двух выбрать, а в 8,2 только общее ДокументСсылка

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Какая разница? Если у тебя документ типизирован, то там срабатывает если не типизирован, т.е. может вернуть Неопределено, тогда лучше использовать ЗначениеЗаполнено(). Это условие которое я вам дал должно отрабатывать!!!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15921
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 624
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 234
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal