Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает Если...Тогда  (Прочитано 1502 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mahaidor

  • **
  • Сообщений: 68
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Задам возможно глупый вопрос, но решить его не могу. Есть объект типа Перечисление - Пол.   Если хочу получить пол из документа в сообщении:
Сообщить(Объект.Пол);
Работает.  Получаю сообщение с текстом "Мужской"
А когда ввожу условие:
Если Объект.Пол="Мужской" Тогда Сообщить(Объект.Пол) КонецЕсли;
то сообщение не выходит, как будто условие  неудовлетворенно.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну так если пол - это перечисление, то не надо сравнивать его со строкой. Должно быть что-то типа:

Если Объект.Пол=Перечисления.Пол.Мужской Тогда Сообщить(Объект.Пол) КонецЕсли;

Оффлайн l2qwe

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 5
  • КПД: 25%
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 8.1
Или как вариант
Если Строка(Объект.Пол)="Мужской" Тогда Сообщить(Объект.Пол) КонецЕсли;

Оффлайн mahaidor

  • **
  • Сообщений: 68
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Ну так если пол - это перечисление, то не надо сравнивать его со строкой. Должно быть что-то типа:

Если Объект.Пол=Перечисления.Пол.Мужской Тогда Сообщить(Объект.Пол) КонецЕсли;
я так делал - не работает
Добавлено: 11 Апр 2014, 02:47

Или как вариант
Если Строка(Объект.Пол)="Мужской" Тогда Сообщить(Объект.Пол) КонецЕсли;
а так работает.спасибо большое.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Так не работает скорее всего из-за того, что в контексте клиента выполняете.

Оффлайн mahaidor

  • **
  • Сообщений: 68
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Так не работает скорее всего из-за того, что в контексте клиента выполняете.
Верно, в контексте клиента. Все ясно, забыл что контекст клиента имеет ограничения.


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 277
Последний ответ 21 Сен 2017, 10:33
от Insider
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4092
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3660
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3757
Последний ответ 20 Июн 2011, 11:14
от Zvezo
Работает ли программа "1С:Управление торговлей 8" на реальных предприятиях?

Автор БоняРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3110
Последний ответ 25 Июл 2008, 15:23
от Мерзлов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 294
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal