Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь в понимании ошибки  (Прочитано 1796 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AleksandrZemtsev

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-09
  • Сайт: 
  • Профессия: Ученик 1С
День добрый!
Решил спросить здесь, так как постеснялся со своим примитивизмом не позорится в серьезных темах.
Дело собственно в том имею небольшой видео курс по 1C8.2 и понемногу его изучаю. Возникла проблема автор курса прикладывает к каждому уроку срез базы на его окончание. У автора конфигурация компилируется нормально без ошибок. А у меня с такими же операциями не выскакивают ошибки. Причем разница в одной процедуре которую я создаю(по уроку). Самое забавное, что и у меня и у автора процедура написана символ в символ. Но у меня не компилируется.
Во вложении конфигурация автора "04", моя конфигурация "проблемная", а также скрин с ошибками.
Люди добрые кому не лень посмотрите в чем "фишка", я так подозреваю, что "что-то глобальное". Если не сложно объяснить не очень заумно почему так происходить.
ЗЫ Знайте я ничего толком еще не понимаю.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Проблема где то в Справочник.Контрагенты.Форма.ФормаЭлемента ....

Так нельзя писать. Что у вас там и для чего не разбирался, потому что определял по скриншоту. Приведите текст модуля для более детального анализа.

Оффлайн AleksandrZemtsev

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-09
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура МенеджерПриИзменении(Элемент)
Если Не Проверка(Объект.Менеджер) Тогда
Сообщить("Не  работает!");
КонецЕсли;

КонецПроцедуры

&НаСервереБезКонтекста
Функция  Проверка(Менеджер)

Возврат Менеджер.Работающий;

КонецФункции

&НаКлиенте
Процедура ВалютаПриИзменении(Элемент)
Установитькурс(Объект.Валюта,ТекущийКурс);
КонецПроцедуры


&НаСервере
ПРоцедура УстановитьКурс(Валюта,ТекущийКурс)
Если Валюта.Пустая() Тогда
ТекущийКурс=0;
Иначе
ТекущийКурс=ПолучитьКурс(Валюта);
КонецЕсли;


Конецпроцедуры;

//&НаСервере
//Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// Установитькурс(Объект.Валюта,ТекущийКурс);
//КонецПроцедуры



Вот Текст модуля. То что закоментированно в конце и вызывает ошибку.

Последний раз редактировалось: MuI_I_Ika; 10 Апр 2014, 14:34

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А вот это не вызывает ошибку?:

&НаКлиенте
Процедура ВалютаПриИзменении(Элемент)
   Установитькурс(Объект.Валюта,ТекущийКурс);
КонецПроцедуры

Еще интересно формы управляемые или обычные?

Оффлайн AleksandrZemtsev

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-09
  • Сайт: 
  • Профессия: Ученик 1С
Еще интересно формы управляемые или обычные?
Режим запуска управляемое приложение.



Вот собственно закомментированное, это и есть то , что вызывает ошибку при компиляции. я эту процедуру закомментировал.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А понял.

В процедуре УстановитьКурс после Конецпроцедуры; уберите точку с запятой.

Оффлайн AleksandrZemtsev

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-09
  • Сайт: 
  • Профессия: Ученик 1С
А понял.

В процедуре УстановитьКурс после Конецпроцедуры; уберите точку с запятой.


Спасибо!
ЗЫ Вот как такое может получатся!? Я же обнюхал весь модуль, а не заметил ";"


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal