Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ввод разных документов на основании разных табличных частей  (Прочитано 1635 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Andrio48

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-03
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Пишу собственную конфигурацию на 8.2, новичок в 1с - набираюсь опыта.
Задача стоит следующая.
Имеется документ "Заказ" с табличными частями "Материалы для монтажа дымохода", "Материалы для монтажа облицовки" и подобные.
Необходимо на основании каждой ТЧ документа "Заказ" создавать документ "РасходнаяНакладная" с реквизитом блок, который содержит наименование ТЧ документа-основания "Заказ" (например, "Материалы для монтажа дымохода") и, соответственно, табличная часть "РасходнойНакладной" должна содержать список материалов табличной части  "Материалы для монтажа дымохода"
Надеюсь, более менее понятно объяснил. В интернете много информации, но никак не могу собрать всё в кучу что бы работало.
Как я себе представляю нужно для каждой ТЧ документа заказ создать свою команду, но что там писать никак не могу сообразить.

Для наглядности результат должен быть таким.


Оффлайн Andrio48

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-03
  • Сайт: 
  • Профессия: Ученик 1С
Решение найдено. Может кому пригодится. Создаём команду в модуле формы документа-основания, которой вызываем процедуру из модуля формы документа "РасходнаяНакладная". Код ниже

Процедура в модуле формы документа-основания
&НаКлиенте
Процедура ВводНаОснованииТопкаМатериалы(Команда)
Форма = получитьФорму("Документ.РасходнаяНакладная.Форма.ФормаДокумента");
Форма.ЗаполнитьНаКлиенте(Объект.Договор, Блок);
    Форма.Открыть();
КонецПроцедуры


Процедура в модуле формы РасходнойНакладной
&НаКлиенте
Процедура ЗаполнитьНаКлиенте(Договор, Блок) экспорт
       Заполнить_Сервер(Договор, Блок)
КонецПроцедуры

&НаСервере
Процедура Заполнить_Сервер(Договор, Блок)
    Док = Документы.РасходнаяНакладная.СоздатьДокумент();
    Для каждого Строка из Блок цикл
        Стр = Док.Смета.Добавить();
Стр.Материал = Строка.Наименование;
Стр.Количество = Строка.Количество;
Стр.ЦенаФакт = Строка.ЦенаОпт;
Стр.СуммаФакт = Строка.СуммаОпт;
    КонецЦикла;
    Док.Дата = ТекущаяДата();
    Док.Договор = Договор;
    ЗначениеВРеквизитФормы(док,"ОБъект");
КонецПроцедуры


Теги:
 

Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4100
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 179
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3026
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1787
Последний ответ 24 Янв 2014, 13:55
от mspuz
Неясна схема создания документов в "1С: ERP УП 2.1".

Автор РексарычРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1857
Последний ответ 29 Июн 2016, 12:04
от Sandi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal