Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 22:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание команд Отбора  (Прочитано 3537 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dazer

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-08
  • Сайт: 
  • Профессия: Программист 1С
Всем привет. Я создал справочник в управляемом приложении 1С 8.2 и в нем же (управляемом приложении), мне нужно открывать 1С Предрпиятие. При этом, я делаю отбор через "Все действия". Это не очень удобно, хочу сделать кнопки (команды) какие есть в отборе (отбор по значению и т.д.). Какой и где нужно написать код?
 Это не динамический список, если что.


Оффлайн l2qwe

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 5
  • КПД: 25%
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 8.1
Пример установки отбора на элемент формы.

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Либо вытащить стандартный отбор из панели команд.

Оффлайн Dazer

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-08
  • Сайт: 
  • Профессия: Программист 1С
Пример установки отбора на элемент формы.

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Этот код на клиенте или на сервере писать? И в каком модуле?

Оффлайн l2qwe

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 5
  • КПД: 25%
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 8.1
Это на клиенте.

Оффлайн Dazer

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-08
  • Сайт: 
  • Профессия: Программист 1С
Это на клиенте.

В справочнике получился такой код, выдает ошибку

&НаСервере
Процедура ПриИзмененииПользователя()
   Объект.Кабинет = объект.Пользователь.Кабинет;
КонецПроцедуры   
&НаКлиенте
Процедура ПользовательПриИзменении(Элемент)
   ПриИзмененииПользователя();
КонецПроцедуры

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Оффлайн l2qwe

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 5
  • КПД: 25%
  • Регистрация: 2014-03-28
  • Сайт: 
  • Профессия: Программист 8.1

В справочнике получился такой код, выдает ошибку

&НаСервере
Процедура ПриИзмененииПользователя()
   Объект.Кабинет = объект.Пользователь.Кабинет;
КонецПроцедуры   
&НаКлиенте
Процедура ПользовательПриИзменении(Элемент)
   ПриИзмененииПользователя();
КонецПроцедуры

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Что то страшное изобразили)
Я привел пример кода который вы уже адаптирует под себя, и используете в нужных для вас местах и в нужном виде
&НаСервере
Процедура ПриИзмененииПользователя()
   Объект.Кабинет = объект.Пользователь.Кабинет;
КонецПроцедуры   
&НаКлиенте
Процедура ПользовательПриИзменении(Элемент)
   ПриИзмененииПользователя();
КонецПроцедуры

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

В какой функции этот участок?
СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Я так подозреваю не в какой.
У вас на форме есть элемент с именем "Свойства"? сомнительно.

Оффлайн Dazer

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-08
  • Сайт: 
  • Профессия: Программист 1С
Ох, почему на форумах никогда не отвечают на вопросы, а только их задают?))

Я потому и спрашиваю, где мне этот код писать. В модуле формы? Функция мне нужна кнопок Отбора (Кто ж не знает, что такое Отбор?), и как мне кнопки к своим данным привязать. Какой элемент "Свойства"? К чему это?
И не "не в какой", а "НИ в какой"...
Добавлено: 09 Апр 2014, 11:03


В справочнике получился такой код, выдает ошибку

&НаСервере
Процедура ПриИзмененииПользователя()
   Объект.Кабинет = объект.Пользователь.Кабинет;
КонецПроцедуры   
&НаКлиенте
Процедура ПользовательПриИзменении(Элемент)
   ПриИзмененииПользователя();
КонецПроцедуры

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Что то страшное изобразили)
Я привел пример кода который вы уже адаптирует под себя, и используете в нужных для вас местах и в нужном виде
&НаСервере
Процедура ПриИзмененииПользователя()
   Объект.Кабинет = объект.Пользователь.Кабинет;
КонецПроцедуры   
&НаКлиенте
Процедура ПользовательПриИзменении(Элемент)
   ПриИзмененииПользователя();
КонецПроцедуры

СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

В какой функции этот участок?
СтрОтбора = Новый ФиксированнаяСтруктура("Код", "111");
Элементы.Свойства.ОтборСтрок =СтрОтбора;

Я так подозреваю не в какой.
У вас на форме есть элемент с именем "Свойства"? сомнительно.

Речь идет об элементарном коде в 3-4 строчки, а вы про Свойства.

Последний раз редактировалось: Dazer; 09 Апр 2014, 11:03. Причина: Объединение сообщений


Теги: Отбор 1С 8.2 
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4472
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4442
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3873
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 7831
Последний ответ 09 Сен 2015, 13:01
от Елена1986
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1183
Последний ответ 26 Сен 2016, 16:25
от NataVl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 307
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal