Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение одного реквизита формы документа при изменении другого 8.2  (Прочитано 2676 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, подскажите, пожалуйста. Как правильно написать код, при котором при изменении поля Получатель формы документа будут автоматически устанавливаться Поля БанкПолучателя и РСПолучателя (которые ссылаются на справочник Контрагенты). Вот моя неудачная попытка (процедура на сервере - написана как в 8.1):

&НаКлиенте
Процедура ПолучательПриИзменении(Элемент)
ПолучитьРеквизитыНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПолучитьРеквизитыНаСервере()
// Установить банк и банковский счет
БанкПолучателя = Получатель.БанкПолучателя;
РСПолучателя = Получатель.РС;
КонецПроцедуры

Сейчас он выдает ошибку {Документ.СписаниеДенежныхСредств.Форма.ФормаДокумента.Форма(18,19)}: Переменная не определена (Получатель)
   БанкПолучателя = <<?>>Получатель.БанкПолучателя; (Проверка: Сервер)
Так же и для РСПолучателя.

Как исправить? Заранее спасибо!



Оффлайн DmitriyF

  • *****
  • Сообщений: 730
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте, подскажите, пожалуйста. Как правильно написать код, при котором при изменении поля Получатель формы документа будут автоматически устанавливаться Поля БанкПолучателя и РСПолучателя (которые ссылаются на справочник Контрагенты). Вот моя неудачная попытка (процедура на сервере - написана как в 8.1):

&НаКлиенте
Процедура ПолучательПриИзменении(Элемент)
ПолучитьРеквизитыНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПолучитьРеквизитыНаСервере()
// Установить банк и банковский счет
БанкПолучателя = Получатель.БанкПолучателя;
РСПолучателя = Получатель.РС;
КонецПроцедуры

Сейчас он выдает ошибку {Документ.СписаниеДенежныхСредств.Форма.ФормаДокумента.Форма(18,19)}: Переменная не определена (Получатель)
   БанкПолучателя = <<?>>Получатель.БанкПолучателя; (Проверка: Сервер)
Так же и для РСПолучателя.

Как исправить? Заранее спасибо!
Объект.Получатель.БанкПолучателя

Оффлайн Амалия

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, подскажите, пожалуйста. Как правильно написать код, при котором при изменении поля Получатель формы документа будут автоматически устанавливаться Поля БанкПолучателя и РСПолучателя (которые ссылаются на справочник Контрагенты). Вот моя неудачная попытка (процедура на сервере - написана как в 8.1):

&НаКлиенте
Процедура ПолучательПриИзменении(Элемент)
ПолучитьРеквизитыНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПолучитьРеквизитыНаСервере()
// Установить банк и банковский счет
БанкПолучателя = Получатель.БанкПолучателя;
РСПолучателя = Получатель.РС;
КонецПроцедуры

Сейчас он выдает ошибку {Документ.СписаниеДенежныхСредств.Форма.ФормаДокумента.Форма(18,19)}: Переменная не определена (Получатель)
   БанкПолучателя = <<?>>Получатель.БанкПолучателя; (Проверка: Сервер)
Так же и для РСПолучателя.

Как исправить? Заранее спасибо!
Объект.Получатель.БанкПолучателя

Да, это конечно хорошо. Я теперь поняла в чем ошибка была. Объект работает с РС, т.к. он забит непосредственно в справочнике Контрагенты. А как быть с банком, если он так же есть в справочнике Контрагенты, но ссылается на другой справочник Банки?
Добавлено: 10 Апр 2014, 14:35

И еще. А то тогда сразу забыла уточнить. Документ этот (Списание денежных средств) вводится на основании другого. Таким образом Получатель автоматически попадает в Списание денежных средств. И БанкПолучателя с РСПолучателя должны заполняться при его создании.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4491
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7764
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4795
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8573
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7357
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal