Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Сен 2020, 09:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: автозаполнение элемента формы документа при заполнении другого элемента формы документа  (Прочитано 7352 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mahaidor

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. 1С 8.3. Справочник "Учащиеся" с полями "ФИО" и "Класс". Документ "Обследование" с полями "ФИО" (тип СправочникСсылка.Учащиеся) и "Класс" (тип Строка). Как сделать так, чтобы после заполнения поля ФИО в документе, автоматически заполнялось поле класс в документе.  Например, в справочнике есть ученик Мохов В.И., класс 7а. Так вот в документе фио этого ученика выбирается из списка справочника, а поле класс документа должно получить значение "7а".


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 55
  • КПД: 19%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
В обработчике события элемента формы "ФИО" документа "Обследование" прописать код. Примерно такой (синтаксис не проверял, могут быть баги! :) )
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
Объект.Класс = ПолучитьКлассУчащегося(Объект.ФИО);
КонецПроцедуры
&НаСервереБезКонтекста
Функция ПолучитьКлассУчащегося(Учащийся)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Учащиеся.Класс
|ИЗ
| Справочник.Учащиеся КАК Учащиеся
|ГДЕ
| Учащиеся.Ссылка = &Учащийся";
Запрос.УстановитьПараметр("Учащийся", Учащийся);
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Если Выборка.Следующий() Тогда
    Возврат Выборка.Класс;
        Иначе
            Возврат "";
КонецЕсли;
КонецФункции

Оффлайн mahaidor

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-06
  • Сайт: 
  • Профессия: Ученик 1С
спасибо.Проверю код, главное что вы мне направление указали.Будут баги,разберусь.:zebzdr:
Добавлено: 06 Апр 2014, 12:27

код рабочий, багов нет. Респект и уважуха Садовод:D:zebzdr::ooifh:

Последний раз редактировалось: mahaidor; 06 Апр 2014, 12:27. Причина: Объединение сообщений

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 55
  • КПД: 19%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
На здоровье :)
Ну а теперь лови упрощённый вариант функции :)
&НаСервереБезКонтекста
Функция ПолучитьКлассУчащегося(Учащийся)
     Возврат ?(ЗначениеЗаполнено(Учащийся), Учащийся.Класс, "");
КонецФункции
Но вариант с запросом более универсальный, позволяет выбирать данные в гораздо более сложных ситуациях.


Теги:
 

Очищается один реквизит объекта на форме при изменении другого реквизита объекта на форме

Автор AsadRomanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 3229
Последний ответ 03 Авг 2018, 17:37
от AsadRoman
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6290
Последний ответ 13 Апр 2012, 23:26
от Vit1501
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3091
Последний ответ 09 Ноя 2017, 08:47
от alex0402
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7782
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3658
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
LexaK
25 Сообщений
antoneus antoneus
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 505
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal