Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программное создание документов на основании табличной части  (Прочитано 1411 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Andrio48

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-03
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Скажу сразу - я новичок в 1с. Разрабатываю собственную конфигурацию для дипломной работы. Столкнулся с следующей задачей:
Имеется документ "Заказ" с табличной частью "список материалов", которая содержит реквизиты: наименование, поставщик, кол-во и др.
И документ "Заявка на материалы" с реквизитом "Поставщик" и табличной частью с реквезитами наименование, кол-во и др.
Так же регистр накопления с измерением "наименование" и ресурсом "КоличествоОстаток" и др..

Необходимо, что бы при проведение документа заказ, в случае нехватки материалов создавались документы "Заявка на материалы" каждому поставщику, которые указаны в табличной части документа "Заказ".

Пока что только смог реализовать методом сообщить, но никак не могу придумать как реально создавать "заявки". А именно в каком месте кода. Возможно, вообще стоит изменить алгоритм??

Что бы было более понятно скриншот прилагается:


Процедура ниже.
&НаСервере
Процедура ПроверитьНаличиеИСоздатьЗаявки()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Заказ.Ссылка,
| ЗаказТопкаМатериалы.Ссылка КАК Ссылка1,
| ЗаказТопкаМатериалы.НомерСтроки КАК НомерСтроки,
| ЗаказТопкаМатериалы.Наименование,
| ЗаказТопкаМатериалы.Поставщик КАК Поставщик,
| ЗаказТопкаМатериалы.ЕденицаИзмерения,
| ЗаказТопкаМатериалы.Количество КАК Количество,
| ЗаказТопкаМатериалы.ЦенаОпт КАК ЦенаОпт,
| ЗаказТопкаМатериалы.СуммаОпт КАК СуммаОпт,
| ЗаказТопкаМатериалы.Наценка КАК Наценка,
| ЗаказТопкаМатериалы.ЦенаРозн КАК ЦенаРозн,
| ЗаказТопкаМатериалы.СуммаРозн КАК СуммаРозн,
| ОстаткиМатериаловОстатки.Номенклатура,
| СУММА(ОстаткиМатериаловОстатки.КоличествоОстатокОстаток) КАК КоличествоОстатокОстаток,
| СУММА(ОстаткиМатериаловОстатки.КоличествоРезервОстаток) КАК КоличествоРезервОстаток,
| СУММА(ОстаткиМатериаловОстатки.КоличествоЗаявкаОстаток) КАК КоличествоЗаявкаОстаток
|ИЗ
| Документ.Заказ.ТопкаМатериалы КАК ЗаказТопкаМатериалы
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.Заказ КАК Заказ
| ПО ЗаказТопкаМатериалы.Ссылка = Заказ.Ссылка
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки КАК ОстаткиМатериаловОстатки
| ПО ЗаказТопкаМатериалы.Наименование = ОстаткиМатериаловОстатки.Номенклатура
|ГДЕ
| Заказ.Ссылка = &Ссылка
|
|СГРУППИРОВАТЬ ПО
| ЗаказТопкаМатериалы.Поставщик,
| Заказ.Ссылка,
| ЗаказТопкаМатериалы.Ссылка,
| ЗаказТопкаМатериалы.НомерСтроки,
| ЗаказТопкаМатериалы.Наименование,
| ЗаказТопкаМатериалы.ЕденицаИзмерения,
| ЗаказТопкаМатериалы.Количество,
| ЗаказТопкаМатериалы.ЦенаОпт,
| ЗаказТопкаМатериалы.СуммаОпт,
| ЗаказТопкаМатериалы.Наценка,
| ЗаказТопкаМатериалы.ЦенаРозн,
| ЗаказТопкаМатериалы.СуммаРозн,
| ОстаткиМатериаловОстатки.Номенклатура
|
|УПОРЯДОЧИТЬ ПО
| Поставщик";

Запрос.УстановитьПараметр("Ссылка", Объект.Ссылка);
Результат = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();

ПоставщикПеременная = "";

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Если ВыборкаДетальныеЗаписи.КоличествоОстатокОстаток < ВыборкаДетальныеЗаписи.Количество тогда
Если НЕ (ВыборкаДетальныеЗаписи.Поставщик=ПоставщикПеременная) тогда
ПоставщикПеременная = ВыборкаДетальныеЗаписи.Поставщик;
Сообщить("Создана заявка поставщику "+ВыборкаДетальныеЗаписи.Поставщик);
КонецЕсли;

Сообщить("Материал "+ВыборкаДетальныеЗаписи.Наименование+" добавлен в заявку");
Сообщить("В заказе: "+ВыборкаДетальныеЗаписи.Количество+"шт.");
Сообщить("На складе: "+ВыборкаДетальныеЗаписи.КоличествоОстатокОстаток+"шт.");

КонецЕсли;
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
КонецПроцедуры


Надеюсь на вашу помощь.
Заранее спасибо)


Оффлайн Andrio48

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-03
  • Сайт: 
  • Профессия: Ученик 1С
нашёл решение, помощь не требуется) :zebzdr:


Теги:
 

Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4099
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 175
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3022
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1784
Последний ответ 24 Янв 2014, 13:55
от mspuz
Неясна схема создания документов в "1С: ERP УП 2.1".

Автор РексарычРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1854
Последний ответ 29 Июн 2016, 12:04
от Sandi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal