Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура с указанным именем не определена  (Прочитано 10664 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VanyaLOX

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-02
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день, коллеги! Я пытаюсь разобраться с выполнением процедуры на сервере и написал такой код в Модуле управляемого приложения:

Процедура ПриНачалеРаботыСистемы()
Строка="Привет от клиента!";
СервернаяПроцедура(Строка);
Сообщить(Строка);
КонецПроцедуры
&НаСервере
Процедура СервернаяПроцедура(Параметр)
Параметр="Привет от сервера!";
КонецПроцедуры
Однако на выходе я получаю ошибку
{МодульУправляемогоПриложения(3,2)}: Процедура или функция с указанным именем не определена (СервернаяПроцедура)
<<?>>СервернаяПроцедура(Строка); (Проверка: Тонкий клиент)
{МодульУправляемогоПриложения(3,2)}: Процедура или функция с указанным именем не определена (СервернаяПроцедура)
<<?>>СервернаяПроцедура(Строка); (Проверка: Веб-клиент)
причем без директивы &НаСервере все работает нормально. Скажите почему так происходит?


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Потому что модуль управляемого приложения компилируется только на клиенте.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, коллеги! Я пытаюсь разобраться с выполнением процедуры на сервере и написал такой код в Модуле управляемого приложения:

Процедура ПриНачалеРаботыСистемы()
Строка="Привет от клиента!";
СервернаяПроцедура(Строка);
Сообщить(Строка);
КонецПроцедуры
&НаСервере
Процедура СервернаяПроцедура(Параметр)
Параметр="Привет от сервера!";
КонецПроцедуры
Однако на выходе я получаю ошибку
{МодульУправляемогоПриложения(3,2)}: Процедура или функция с указанным именем не определена (СервернаяПроцедура)
<<?>>СервернаяПроцедура(Строка); (Проверка: Тонкий клиент)
{МодульУправляемогоПриложения(3,2)}: Процедура или функция с указанным именем не определена (СервернаяПроцедура)
<<?>>СервернаяПроцедура(Строка); (Проверка: Веб-клиент)
причем без директивы &НаСервере все работает нормально. Скажите почему так происходит?

Как бы вам помягче сказать :bleh:

В общем, в модуле управляемого приложения нельзя описывать и тем более использовать процедуры на сервере. Выносите их в общий модуль.

Для обучения используйте внешние обработки.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal