Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Иерархический поиск картинки.  (Прочитано 868 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sveya

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-04-02
  • Сайт: 
  • Профессия: Ученик 1С
Обращаюсь к знающим людям. Задача: необходимо во внешней печатной форме "Счет на оплату" вывести картинку снизу. Для этого создается дополнительный справочник "Реклама" (см. прилагаемый файл), в котором указывается путь к картинке и в табличной части выбирается номенклатура (а именно группы, в моем случае группа "Проф"), для которой эта картинка будет действовать. Если  документ "Счет на оплату покупателю" в своей табличной части содержит номенклатуру, которая входит в эту группу "Проф", то, соответственно, в печатной форме выводится картинка, назначенная родителю - группе "Проф". Пишу запрос:
"ВЫБРАТЬ
| Номенклатура.Родитель КАК ГруппаНоменклатуры
|ПОМЕСТИТЬ Группы
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Ссылка В(&МассивНоменклатуры)
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| РекламаНоменклатура.Ссылка,
| РекламаНоменклатура.Ссылка.ПутьККартинке
//| РекламаНоменклатура.Номенклатура
|ИЗ
| Группы КАК Группы
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Реклама.Номенклатура КАК РекламаНоменклатура
| ПО Группы.ГруппаНоменклатуры = РекламаНоменклатура.Номенклатура
|ГДЕ
| РекламаНоменклатура.Ссылка.ДатаНач <= &Дата
| И РекламаНоменклатура.Ссылка.ДатаКон >= &Дата";
Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() цикл
МассивРекламы.Добавить(Результат.Ссылка);
КонецЦикла;

Если МассивРекламы.Количество() = 0 тогда
Выборка = Справочники.Реклама.Выбрать();
Пока Выборка.Следующий() цикл
Если Выборка.ДатаНач <= ТекущаяДата() И Выборка.ДатаКон > ТекущаяДата() И Выборка.ПометкаУдаления = Ложь тогда
МассивРекламы.Добавить(Выборка.Ссылка);
КонецЕсли;
КонецЦикла;
КонецЕсли;

Если МассивРекламы.Количество() = 0 тогда
Сообщить("Нет подходящих рекламных вставок");
Возврат ТабДок;
КонецЕсли;


Но! Проблема в том, что я ищу картинку только у родителя, поэтому если у родителя картинки нет, то нужно искать у вышестоящей папки, то есть у "родителя родителя" и так далее. И, следовательно, запрос изменится. Помогите, пожалуйста. Уже все перепробовала, больше нет мыслей. Спасибо!


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
1. вам нужно не внутреннее соединение, а левое, чтобы выходили все группы номенклатуры
2. группы у которых нет ссылки - РекламаНоменклатура.Ссылка помещать в таблицу значений, которую затем гонять в цикле пока не заполняться все РекламаНоменклатура.Ссылка или у группы будет Родитель = ПустаяСсылка, т.е. пока не будет достигнута самая верхняя группа


Теги:
 

Поиск в справочнике "Номенклатура" в УТ 11

Автор HolicРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1397
Последний ответ 08 Фев 2016, 20:53
от Holic
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 747
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika
Как установить "Поиск по точному совпадению" по умолчанию?

Автор BulatsergРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1676
Последний ответ 16 Сен 2016, 14:58
от Bulatserg
Поиск и замена способа отражения расходов в документе Передача материалов в эксплуатацию

Автор Елена ПлаксинаРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 2565
Последний ответ 08 Авг 2015, 00:37
от Дмитрий@
Поиск в основной форме обработки ссылок на формирование табличной части

Автор Nail2010Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3535
Последний ответ 21 Дек 2010, 10:02
от Nail2010

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 146
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal