Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 06:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обновить открытую форму документа из обработки (обычные формы)  (Прочитано 7596 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн irris

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Возникла проблема. По кнопочке хочу заполнить табличную часть по другому документы. Сделал событие при нажатии на эту кнопку
Процедура КоманднаяПанельТоварыЗаполнитьПоЗаказу(Кнопка)
    Форма = Обработки.ЗаполнениеНарядаПоЗаказу.ПолучитьФорму("Форма");
    // "Ссылочка" - это глобальная экспортная переменная модуля открываемой формы

    Форма.Ссылочка = ЭтотОбъект.Ссылка;
    Форма.Открыть();
КонецПроцедуры

открывается обработка. указываем там нужный документ по которому хотим заполнить и он Заполняет.
Вот код

Перем Ссылочка Экспорт;


Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ЗначениеЗаполнено(Заказ) Тогда
    ЗаказНаряд = наряд.ПолучитьОбъект();
    ЗаказНаряд.Товары.Очистить();
    ЗаказНаряд.Товары.Загрузить(Заказ.Товары.Выгрузить());
    ЗаказНаряд.Записать();
    КонецЕсли;
    ЭтаФорма.Закрыть();
КонецПроцедуры

Процедура ПриОткрытии()
    ЭтотОбъект.Наряд = Ссылочка;
КонецПроцедуры

после закрытии обработки нужно обновить форму открытого документа. никак не получается. Помогает только закрытие и повторное открытие документа. Как можно обновить форму?


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Возникла проблема. По кнопочке хочу заполнить табличную часть по другому документы. Сделал событие при нажатии на эту кнопку
Процедура КоманднаяПанельТоварыЗаполнитьПоЗаказу(Кнопка)
    Форма = Обработки.ЗаполнениеНарядаПоЗаказу.ПолучитьФорму("Форма");
    // "Ссылочка" - это глобальная экспортная переменная модуля открываемой формы

    Форма.Ссылочка = ЭтотОбъект.Ссылка;
    Форма.Открыть();
КонецПроцедуры

открывается обработка. указываем там нужный документ по которому хотим заполнить и он Заполняет.
Вот код

Перем Ссылочка Экспорт;


Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ЗначениеЗаполнено(Заказ) Тогда
    ЗаказНаряд = наряд.ПолучитьОбъект();
    ЗаказНаряд.Товары.Очистить();
    ЗаказНаряд.Товары.Загрузить(Заказ.Товары.Выгрузить());
    ЗаказНаряд.Записать();
    КонецЕсли;
    ЭтаФорма.Закрыть();
КонецПроцедуры

Процедура ПриОткрытии()
    ЭтотОбъект.Наряд = Ссылочка;
КонецПроцедуры

после закрытии обработки нужно обновить форму открытого документа. никак не получается. Помогает только закрытие и повторное открытие документа. Как можно обновить форму?

Форма.Обновить() после модального открытия формы, либо оповещения между открытыми формами.

Оффлайн irris

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо!
Тему закрываю. Всё сделал. Понял что начал делать через одно место,в итоге сделал по другому. Сделал просто с помощью внешней обработки заполнения ТЧ,подцепил к документу и всё получилось.

Оффлайн 43nik

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-09-14
  • Сайт: 
  • Профессия: Программист 1С
Форма = СсылкаНаОбъект.ПолучитьФорму("ФормаДокумента");
Если Форма.Открыта() тогда
   Форма.ДокументОбъект.Прочитать();
   Форма.Обновить();
КонецЕсли;


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17261
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4778
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1202
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8281
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5534
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal