Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 09:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ввод на основании программно в 8,2  (Прочитано 13591 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Пробую Сделать ввод на основании...

На форме документа (ДокИсходный) создала кнопку:
Процедура ДействияФормыЗаказТР(Кнопка)

  НовДок = Документы.ДокНовый.СоздатьДокумент();
  НовДок.Заполнить(Ссылка);
  НовДок.ПолучитьФорму().Открыть();
   
КонецПроцедуры

В свойствах ВВод на основании документа ДокНовый указала что вводится на основании ДокИсходный
и в модуле ДокНовый прописала
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
  Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;
КонецПроцедуры

Вопрос - что не так я делаю? сейчас код отрабатывает без ошибок, но ничего не происходит. Нажимаешь на кнопку, а реакции никакой.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Так у вас же здесь ничего не написано:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Так у вас же здесь ничего не написано:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;

Я просто не стала писать...:nhsrm:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
 //*** заполним шапочку документа
 Контрагент = ДанныеЗаполнения.Контрагент;
 Организация = ДанныеЗаполнения.Организация;
КонецЕсли;

Сейчас я хотела, ХОТЯБЫ, чтобы открылась форма нового документа,а потом уж буду пробывать делать заполнение. Должна ведь форма открываться?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте вместо этого: НовДок.ПолучитьФорму().Открыть();
сделать так:

Форма = НовДок.ПолучитьФорму();
Форма.Открыть();

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте вместо этого: НовДок.ПолучитьФорму().Открыть();
сделать так:

Форма = НовДок.ПолучитьФорму();
Форма.Открыть();
к сожалению не помагает...:dfbsdfbsdf:
в процедуру входит и все! ничего не понимаю...
Действие по кнопке должно мне только открыть форму другого пустого документа, правильно ведь?
Может ли быть загвоздка в том, что в Исходном документе я изменила настройку поддержки с "Не редактируется" на "Редактируется с сохранением поддержки" - для самого документа и для формы документа.???
А ДокументНовый - это самописный документ.? Может из-за этого они никак не подружатся?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Может просто воспользоваться стандартным механизмом ввода на основании. Через кнопочку ввода на основании. Почему она не используется?

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Может просто воспользоваться стандартным механизмом ввода на основании. Через кнопочку ввода на основании. Почему она не используется?
:) да вот... так и делаю... но нужно чтобы еще и кнопочка была прямо у пользователя чуть ли не "на носу" - чтобы ее было вИИИИдно!

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну, ок. Формы обычные или управляемые?

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Ну, ок. Формы обычные или управляемые?
обычные

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну в обычных формах должно все работать.

Вот на этой строке документ заполняется?

НовДок.Заполнить(Ссылка);

Надо поотлаживать что там происходит.


Теги:
 

Программно открыть отчет скд и отчет подключенный как внешний отчет

Автор 1ckaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3928
Последний ответ 02 Фев 2015, 10:06
от 1cka
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3173
Последний ответ 21 Мар 2015, 20:24
от дфтын
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1332
Последний ответ 18 Янв 2017, 12:32
от sertak
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 221
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1044
Последний ответ 15 Сен 2016, 02:46
от ksander-fars

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 600
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal