Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: условия отбора в цикле 1с8.2  (Прочитано 1870 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Есть три ТЗ, ТаблицаПодраз - свернута до подразделения, ТаблицаСотр - до сотрудника, ТаблицаТехОперация - до тех операции.

и есть еще три массива ссылок с отбором по ВыбПодразделение, ВыбСотрудник и ВыбТехнологическаяОперация - реквизиты формы:   
ОтборПодразделения = Новый Структура("ПодразделениеОрганизации", ВыбПодразделение);
МассивСтрокПодразделений = ТаблицаПодраз.НайтиСтроки(ОтборПодразделения);
   
ОтборПоСотруднику = Новый Структура("Сотрудник", ВыбСотрудник);
МассивСтрокСотрудников = ТаблицаСотр.НайтиСтроки(ОтборПоСотруднику);
   
ОтборПоТехОперации = Новый Структура("ТехнологическаяОперация", ВыбТехнологическаяОперация);
МассивСтрокТехОпераций = ТаблицаСотр.НайтиСтроки(ОтборПоТехОперации);

//Сейчас не используя отборы я пишу так:

Для Каждого Стр1 Из ТаблицаПодраз Цикл

//....
     Для Каждого Стр2 Из ТаблицаСотр Цикл
         
    Если Стр1.ПодразделениеОрганизации <> Стр2.ПодразделениеОрганизации ТОгда
       Продолжить;
    КонецЕсли;
//.....
     Для Каждого Стр3 Из ТаблицаТехОперация Цикл
            
          Если Стр2.Сотрудник <> Стр3.Сотрудник ТОгда
   Продолжить;
         КонецЕсли;
//.....

     КонецЦикла;
   КонецЦикла;
КонецЦикла;[/code]

А как добавить условия - если рекизит заполнен, то использовать отбор, если нет - то выводить полный список???Т.е. какой-то из реквизитов может быт заполнен (те используем отбор), какой-то нет (полным списком)
пытаюсь использовать:
Если  ВыбПодразделение = Справочники.Подразделения.ПустаяСсылка() Тогда //по всем подразделения
иначе
//по отбору
КонецЕсли;
Подскажите как правильно добавить это условие для каждого уровня?


Теги:
 

Внесение в настройки отчета "Расчет среднегодовой стоимости имущества" нового отбора

Автор Костромской ЦГМСРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 832
Последний ответ 08 Сен 2015, 09:55
от Костромской ЦГМС
упр.прил. Как докопаться до структуры отбора "Найти..." в форме списка

Автор HakenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2238
Последний ответ 23 Ноя 2012, 11:12
от Haken
Что лучше использовать для поиска связи между документами записи в регистре или критерии отбора

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 968
Последний ответ 05 Сен 2016, 11:26
от ilyay
Создание отбора отдельным элементом на форме внешнего отчета через настройки скд без программирования.

Автор MeatCrashРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 743
Последний ответ 14 Янв 2017, 10:14
от MeatCrash
Дублирование пользователей в списке отбора, при открытие его через Журнал регистрации.

Автор Idea73Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 588
Последний ответ 20 Мар 2016, 17:19
от Idea73

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 130
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal