Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 11:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: {(1, 1)}: Ожидается выражение "ВЫБРАТЬ"  (Прочитано 9607 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
Всем доброго утречка!

Чет никак не могу разобраться в чем можеть быть ошибка...
/////////////////////////////////////////////////////////////////////////////////////////////
{Отчет.ц_Форма36.Форма.ФормаОтчета(205)}: Ошибка при вызове метода контекста (Выполнить)
   Результат = Запрос.Выполнить();
по причине:
{(1, 1)}: Ожидается выражение "ВЫБРАТЬ"


////////////////////////////////////////////////

Запрос = Новый Запрос;

   Запрос.Текст="ВЫБРАТЬ
                |   ВложенныйЗапрос.ТипОперации,
                |   ВложенныйЗапрос.Влажность КАК Влажность,
                |   ВложенныйЗапрос.СорнаяПримесь КАК СорнаяПримесь,
                |   ВложенныйЗапрос.Номенклатура,
                |   ВложенныйЗапрос.Клейковина,
                |   СУММА(ВложенныйЗапрос.ПриходФизическийВес) КАК ПриходФизическийВес,
                |   СУММА(ВложенныйЗапрос.ПриходЦентнероПроцентВлажность) КАК ПриходЦентнероПроцентВлажность,
                |   СУММА(ВложенныйЗапрос.ПриходЦентнероПроцентСорнаяПримесь) КАК ПриходЦентнероПроцентСорнаяПримесь,
                |   СУММА(ВложенныйЗапрос.РасходФизическийВес) КАК РасходФизическийВес,
                |   СУММА(ВложенныйЗапрос.РасходЦентнероПроцентВлажность) КАК РасходЦентнероПроцентВлажность,
                |   СУММА(ВложенныйЗапрос.РасходЦентнероПроцентСорнаяПримесь) КАК РасходЦентнероПроцентСорнаяПримесь,
                |   ВложенныйЗапрос.Коэффициент КАК Коэффициент
                |ИЗ
                |   (ВЫБРАТЬ
                |      ц_ОперативныйУчетФизическогоВеса.ТипОперации КАК ТипОперации,
                |      ц_ОперативныйУчетФизическогоВеса.ПроцентВлажности КАК Влажность,
                |      ц_ОперативныйУчетФизическогоВеса.ПроцентСорнойПримеси КАК СорнаяПримесь,
                |      ц_ОперативныйУчетФизическогоВеса.Номенклатура КАК Номенклатура,
                |      ц_ОперативныйУчетФизическогоВеса.Клейковина КАК Клейковина,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход)
                |            ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК ПриходФизическийВес,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход)
                |            ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_ОперативныйУчетФизическогоВеса.ПроцентВлажности * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент / 100
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК ПриходЦентнероПроцентВлажность,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход)
                |            ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_ОперативныйУчетФизическогоВеса.ПроцентСорнойПримеси * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент / 100
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК ПриходЦентнероПроцентСорнаяПримесь,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ТипОперации <> ЗНАЧЕНИЕ(Справочник.ц_ТипыОпераций.РасходПоОперацииСушка)
                |            ТОГДА ВЫБОР
                |                  КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
                |                     ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент
                |                  ИНАЧЕ 0
                |               КОНЕЦ
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК РасходФизическийВес,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ТипОперации <> ЗНАЧЕНИЕ(Справочник.ц_ТипыОпераций.РасходПоОперацииСушка)
                |            ТОГДА ВЫБОР
                |                  КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
                |                     ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_ОперативныйУчетФизическогоВеса.ПроцентВлажности * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент / 100
                |                  ИНАЧЕ 0
                |               КОНЕЦ
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК РасходЦентнероПроцентВлажность,
                |      ВЫБОР
                |         КОГДА ц_ОперативныйУчетФизическогоВеса.ТипОперации <> ЗНАЧЕНИЕ(Справочник.ц_ТипыОпераций.РасходПоОперацииСушка)
                |            ТОГДА ВЫБОР
                |                  КОГДА ц_ОперативныйУчетФизическогоВеса.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
                |                     ТОГДА ц_ОперативныйУчетФизическогоВеса.ФизВес * ц_ОперативныйУчетФизическогоВеса.ПроцентСорнойПримеси * ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент / 100
                |                  ИНАЧЕ 0
                |               КОНЕЦ
                |         ИНАЧЕ 0
                |      КОНЕЦ КАК РасходЦентнероПроцентСорнаяПримесь,
                |      ц_КоэффициентыПересчетаЕдиницИзмерения.Коэффициент КАК Коэффициент
                |   ИЗ
                |      РегистрНакопления.ц_ОперативныйУчетФизическогоВеса КАК ц_ОперативныйУчетФизическогоВеса
                |         ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ц_КоэффициентыПересчетаЕдиницИзмерения КАК ц_КоэффициентыПересчетаЕдиницИзмерения
                |         ПО ц_ОперативныйУчетФизическогоВеса.Номенклатура.БазоваяЕдиницаИзмерения = ц_КоэффициентыПересчетаЕдиницИзмерения.ЕдИзмРезультирующая
                |   ГДЕ
                |      ц_КоэффициентыПересчетаЕдиницИзмерения.ЕдИзмНачальная = &ЕдИзмРезультирующая
                |      И ц_ОперативныйУчетФизическогоВеса.Организация = &Организация
                |      И ц_ОперативныйУчетФизическогоВеса.Склад = &Склад
                |      И ц_ОперативныйУчетФизическогоВеса.ГодУрожая = &ГодУрожая
                |      И ц_ОперативныйУчетФизическогоВеса.Номенклатура = &Номенклатура
                |      И ц_ОперативныйУчетФизическогоВеса.Фонд = &Фонд
                |      И ц_ОперативныйУчетФизическогоВеса.Клейковина = &Клейковина) КАК ВложенныйЗапрос
                |
                |СГРУППИРОВАТЬ ПО
                |   ВложенныйЗапрос.ТипОперации,
                |   ВложенныйЗапрос.Влажность,
                |   ВложенныйЗапрос.СорнаяПримесь,
                |   ВложенныйЗапрос.Номенклатура,
                |   ВложенныйЗапрос.Клейковина,
                |   ВложенныйЗапрос.Коэффициент";
            
//Запрос.УстановитьПараметр("Контрагент",Контрагент);
Запрос.УстановитьПараметр("Организация",Организация);
Запрос.УстановитьПараметр("Склад", Склад);
Запрос.УстановитьПараметр("Номенклатура", Культура);
Запрос.УстановитьПараметр("ГодУрожая", ГодУрожая);
Запрос.УстановитьПараметр("Фонд", Фонд);
Запрос = Новый Запрос;
   ЭлементКГ = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("166"); // килограмм
   Если ЗначениеЗаполнено(ЭлементКГ) Тогда
      Запрос.УстановитьПараметр("ЕдИзмРезультирующая", ЭлементКГ.Ссылка);
   Иначе
      ц_ОбщегоНазначения.ВывестиСообщение("Единица измерения КИЛОГРАММ не найдена!!!",СтатусСообщения.ОченьВажное);
   
   КонецЕсли;
   
   Результат=Запрос.Выполнить();
   Выборка=Результат.Выбрать();

   Пока Выборка.Следующий() Цикл
   ЭлементыФормы.Надпись1.Значение = Выборка.РасходФизическийВес;
   КонецЦикла;
//////////////////////////////


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)конструктором ОТКРОЙ свой запрос...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
(0)конструктором ОТКРОЙ свой запрос...

открыл...))

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
а ларчик ПРОСТО открывался :lol: :D

{
//Запрос.УстановитьПараметр("Контрагент",Контрагент);
Запрос.УстановитьПараметр("Организация",Организация);
Запрос.УстановитьПараметр("Склад", Склад);
Запрос.УстановитьПараметр("Номенклатура", Культура);
Запрос.УстановитьПараметр("ГодУрожая", ГодУрожая);
Запрос.УстановитьПараметр("Фонд", Фонд);
Запрос = Новый Запрос; :thwrt:
   ЭлементКГ = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("166"); // килограмм
   Если ЗначениеЗаполнено(ЭлементКГ) Тогда
      Запрос.УстановитьПараметр("ЕдИзмРезультирующая", ЭлементКГ.Ссылка);
   Иначе
      ц_ОбщегоНазначения.ВывестиСообщение("Единица измерения КИЛОГРАММ не найдена!!!",СтатусСообщения.ОченьВажное);
   
   КонецЕсли;
   
   Результат=Запрос.Выполнить();}
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
а ларчик ПРОСТО открывался :lol: :D

{
//Запрос.УстановитьПараметр("Контрагент",Контрагент);
Запрос.УстановитьПараметр("Организация",Организация);
Запрос.УстановитьПараметр("Склад", Склад);
Запрос.УстановитьПараметр("Номенклатура", Культура);
Запрос.УстановитьПараметр("ГодУрожая", ГодУрожая);
Запрос.УстановитьПараметр("Фонд", Фонд);
Запрос = Новый Запрос; :thwrt:
   ЭлементКГ = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("166"); // килограмм
   Если ЗначениеЗаполнено(ЭлементКГ) Тогда
      Запрос.УстановитьПараметр("ЕдИзмРезультирующая", ЭлементКГ.Ссылка);
   Иначе
      ц_ОбщегоНазначения.ВывестиСообщение("Единица измерения КИЛОГРАММ не найдена!!!",СтатусСообщения.ОченьВажное);
   
   КонецЕсли;
   
   Результат=Запрос.Выполнить();}

Видать перезанимался : 2 раза написал Запрос = Новый Запрос; СПс


Теги:
 

Как В Запрос=Новый Запрос Из Регистр Накопление Остати Выбрать СуммаПриход По Нужный Реквизитам

Автор Samir OmarovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 1537
Последний ответ 17 Ноя 2016, 08:34
от cska-fanat-kz
Режим диалога выбора файлов - выбрать из нескольких типов файлов.

Автор Yuliya_DenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4257
Последний ответ 19 Апр 2016, 15:28
от Yuliya_Den
Крупнейшие налогоплательщики могут сами выбрать налоговую инспекцию для предоставления формы 2-НДФЛ

Автор newsРаздел Новости

Ответов: 0
Просмотров: 842
Последний ответ 02 Апр 2014, 14:05
от news
Нужно на форму добавить объект, чтобы можно было выбрать из списка документ

Автор RoDiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1561
Последний ответ 05 Июл 2016, 14:04
от RoDi
Выбрать из регистра сведений (срез последних) те записи, у который период МАКС

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 9852
Последний ответ 24 Апр 2012, 07:31
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal