Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчет. 8.2  (Прочитано 1676 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Отчет. 8.2
« Первое сообщение: 18 Мар 2014, 16:52 »
ЗапросПоКоличеству = Новый Запрос;

ЗапросПоКоличеству.Текст =
"ВЫБРАТЬ
| ОтчетПроизводстваЗаСмену.Ссылка
|ИЗ
| Документ.ОтчетПроизводстваЗаСмену КАК ОтчетПроизводстваЗаСмену
|ГДЕ
|ОтчетПроизводстваЗаСмену.Дата МЕЖДУ &НачалоПериода И &КонецПериода
|";

ЗапросПоКоличеству.УстановитьПараметр("НачалоПериода", НачалоДня(НачалоПериодаОтчета));
ЗапросПоКоличеству.УстановитьПараметр("КонецПериода", КонецДня(ОкончаниеПериодаОтчета));
   
ВыборкаПоКоличеству = ЗапросПоКоличеству.Выполнить().Выгрузить();//Выбрать();//

//ТаблицаПодраз = ВыборкаПоКоличеству.Скопировать();
//ТаблицаПодраз.Свернуть("Подразделение", "Количество");

Написала запрос через ссылку, приведенный выше.
Можно ли теперь  нужные мне данные свернуть в ТЗ? Примерно как в двух последних строчках кода. Как обращаться к именам колонок (к реквизитам документа и ТЧ)? Раньше в 8.1 имена колонок определялись в запросе, а здесь как быть?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Отчет. 8.2
« Ответ #1: 18 Мар 2014, 16:56 »
Не понял в чем вопрос заключается. Как свернуть таблицу вы знаете. Как называются колонки в запросе тоже знаете судя по конструкциям в запросе. Или вопрос в том как свернуть таблицу в запросе?

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчет. 8.2
« Ответ #2: 18 Мар 2014, 21:21 »
Не понял в чем вопрос заключается. Как свернуть таблицу вы знаете. Как называются колонки в запросе тоже знаете судя по конструкциям в запросе. Или вопрос в том как свернуть таблицу в запросе?
Как называются колонки в запросе?
Так как я пишу
ТаблицаПодраз.Свернуть("Подразделение", "Количество");
Пишет ошибку: Неверное имя колонки!
те здесь Подразделение - это реквизит шапки докумнта, а Количество - это колонка ТЧ
Т.е. вопрос в том, как, например, выбрать (как правильно указать имя колонки) из ТЧ Тех.операции - Наименование тех.операции и ее количество?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Отчет. 8.2
« Ответ #3: 19 Мар 2014, 09:56 »
Ну еще вам осталось научиться пользоваться отладчиком. Он позволяет посмотреть какие колонки есть в таблице.

Судя по запросу там выбирается одно единственное поле Ссылка. Исли у вас возникают вопросы при именовании полей, то используйте в запросе конструкцию КАК, которой вы воспользовались при именовании таблицы.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Re: Отчет. 8.2
« Ответ #4: 20 Мар 2014, 16:17 »
ЗапросПоКоличеству = Новый Запрос;

ЗапросПоКоличеству.Текст =
"ВЫБРАТЬ
| ОтчетПроизводстваЗаСмену.Ссылка
|ИЗ
| Документ.ОтчетПроизводстваЗаСмену КАК ОтчетПроизводстваЗаСмену
|ГДЕ
|ОтчетПроизводстваЗаСмену.Дата МЕЖДУ &НачалоПериода И &КонецПериода
|";

ЗапросПоКоличеству.УстановитьПараметр("НачалоПериода", НачалоДня(НачалоПериодаОтчета));
ЗапросПоКоличеству.УстановитьПараметр("КонецПериода", КонецДня(ОкончаниеПериодаОтчета));
   
ВыборкаПоКоличеству = ЗапросПоКоличеству.Выполнить().Выгрузить();//Выбрать();//

//ТаблицаПодраз = ВыборкаПоКоличеству.Скопировать();
//ТаблицаПодраз.Свернуть("Подразделение", "Количество");

Написала запрос через ссылку, приведенный выше.
Можно ли теперь  нужные мне данные свернуть в ТЗ? Примерно как в двух последних строчках кода. Как обращаться к именам колонок (к реквизитам документа и ТЧ)? Раньше в 8.1 имена колонок определялись в запросе, а здесь как быть?
Вот в чем загвоздка:
Пока Выборка.Следующий() Цикл
    Отчет = Выборка.ссылка;
Для Каждого Стр Из Отчет.Исполнители Цикл
    НоваяСтрока = ТаблицаРезультата.Добавить();
    НоваяСтрока.Сотрудник = Стр.Сотрудник;
КонецЦикла;
КонецЦикла;
если писать так, то можно обратиться к ТЧ и все прекрасно работает
а когда использую Свернуть(), то получается нельзя!

вопрос, как добавить условие к этому запросу, типа
Если Не ВыбСотрудник = Справочники.СотрудникиОрганизаций.ПустаяСсылка() Тогда
Запрос.Текст = Запрос.Текст+
"
|
|И ОтчетПроизводстваЗаСмену.Ссылка.Исполнители.Сотрудники = &ВыбСотрудник";
КонецЕсли;
соответственно так как написано не работает. КАк обратиться к сотруднику из ТЧ Исполнители?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 264
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal