Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 23:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как Скрыть кнопку в форме Документа  (Прочитано 3891 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Как Скрыть кнопку в форме Документа


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Свойство "Видимость".

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Свойство "Видимость".
Сделал так, но не работает(( что не так? кнопка находится на ОСновныеДействияФормы-это как-то меняет суть??
Процедура ПриОткрытии()
    Если ПользователиИнформационнойБазы.ТекущийПользователь().Имя = "Вася" Тогда
        ЭлементыФормы.Записать.Видимость = Ложь
    КонецЕсли;

Оффлайн knopodav

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-11
  • Сайт: 
  • Профессия: Программист 1С
ЭлементыФормы.ИмяКнопкиНаФорме.Видимость = Ложь; //Если кнопка расположена просто на форме 
Если кнопка расположена в командной панели тогда беда! :fdbsdfbsd: никак её не скрыть! Только удалять...
УбитаяКнопка = ЭлементыФормы.КоманднаяПанель1.Кнопки.Найти("ИмяКнопкиНаФорме"); //Попытались найти кнопочку
      Если ЗначениеЗаполнено(УбитаяКнопка) Тогда                                      //если найдена
          ЭлементыФормы.КоманднаяПанель1.Кнопки.Удалить(УбитаяКнопка);                //грохнем её
      КонецЕсли;
как то так...

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
УбитаяКнопка = ЭлементыФормы.КоманднаяПанель1.Кнопки.Найти("ИмяКнопкиНаФорме"); //Попытались найти кнопочку
      Если ЗначениеЗаполнено(УбитаяКнопка) Тогда                                      //если найдена
          ЭлементыФормы.КоманднаяПанель1.Кнопки.Удалить(УбитаяКнопка);                //грохнем её
      КонецЕсли;
после этого она совсем пропадет?? и будет недоступна всем??


Оффлайн knopodav

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-11
  • Сайт: 
  • Профессия: Программист 1С
На время жизни окна кнопка пропадёт совсем только для того пользователя который открыл окно ("Васи", в нашем случае) другие её будут видить. Если кнопка понадобиться потом (в этой экранной форме) надо будет её создавать.
А вообще грамотней будет её просто "затемнить" (Доступность = Ложь)..

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
А вообще грамотней будет её просто "затемнить" (Доступность = Ложь).
так и поступил



Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15931
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 629
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7744
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
41 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal