Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при загрузке почты  (Прочитано 2717 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Юрий Д

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-20
  • Сайт: 
  • Профессия: Бухгалтер
Почта настроена верно. Отправляет и получает письма. Имеется несколько почтовых ящиков. Сначала все было хорошо, затем ошибка проявилась сначала на одном ящике, потом на другом и не подгружает почту, останавливается. Подскажите это программная ошибка или не верно сделал настройки почты, если да то как это поправить. Спасибо.

Ошибка следующего содержания:
{ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(207)}: Метод объекта не обнаружен (tags)
      ТегиКартинок = НовыйHTMLДокумент.all.tags("img");

Конфигурация стандартная, не изменяли.
1С: Предприятие 8.2 (8.2.19.83)
Конфигурация:
Комплексная автоматизация, редакция 1.1 (1.1.45.1)


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А вы случайно Internet Explorer недавно не обновляли?

Оффлайн Shef21

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 1
  • КПД: 10%
  • Регистрация: 2017-08-29
  • Сайт: 
  • Профессия: Ученик 1С
Так всё-таки, чем и как решилась эта проблема.
У самого УТ 10.3.45.2 (вчера обновил до последней версии) SQL-ный вариант.
Стояла и стоит stunnel. Почта yandex.ru
При получении писем, возникает та же самая ошибка, что и у Вас:
{ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(204)}: Метод объекта не обнаружен (tags) ТегиКартинок = НовыйHTMLДокумент.all.tags("img");
Решения не могу найти. Поиск по ошибке не рулит вообще ни разу.

Вот кусок этого кода, но он типовой:
Если ЗначениеЗаполнено(ХТМЛ_Текст) Тогда
Если УстанавливатьВидТекстаПисьма Тогда
ПисьмоОбъект.ВидТекстаПисьма = Перечисления.ВидыТекстовЭлектронныхПисем.HTML;
КонецЕсли;
НовыйHTMLДокумент = Новый COMОбъект("HtmlFile");
НовыйHTMLДокумент.open("text/html");
НовыйHTMLДокумент.write(ХТМЛ_Текст);
НовыйHTMLДокумент.close();
ТегиКартинок = НовыйHTMLДокумент.all.tags("img");
Для а = 0 По ТегиКартинок.length - 1 Цикл
ИсточникКартинки = ТегиКартинок.item(а).src;
Если Найти(ИсточникКартинки, "cid:") = 1 Тогда
ИсточникКартинки = Сред(ИсточникКартинки, 5);
ТегиКартинок.item(а).src = ИсточникКартинки;
КонецЕсли;
КонецЦикла;

Не пойму, получается он не может принять письмо с картинками, или не может им присвоить cid.
Добавлено: 10 Окт 2017, 15:46

Прошу Вашей помощи, уважаемые знатоки 1ССС
Добавлено: 10 Окт 2017, 17:44

А вот теперь точно странно. Поднял с копии базу 1 дневной, недельной и месячной дневной давности - ошибка та же.
Добавлено: 11 Окт 2017, 09:05

Попробую вариант полностью очистить от писем "Менеджер контактов". И еще раз получить почту, при этом оставив на внешней почта только пару писем.
Добавлено: 12 Окт 2017, 08:44

Вот, что странно:
Очистил всю почту с 1С УТ, на сервере yandex.ru очистил тоже все папки с письмами.
В 1С УТ нажимаю принять почту - загружает 10 каких-то сообщений (???) откуда-то (???) и вываливается с ошибкой.
Откуда берутся эти 10ть сообщений - неизвестно....
Удалил из 1С аккаунт почты - создал новый с теми же данными - ничего не поменялось.
Подскажите, есть ли у кого какие мысли?

Последний раз редактировалось: Shef21; 12 Окт 2017, 08:44. Причина: Объединение сообщений


Теги: tag Почта 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal