Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка установки параметра сеанса  (Прочитано 3762 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NetWorm

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-02
  • Сайт: 
  • Профессия: Разработчик 1С
Создал параметр сеанса "Текущий период" тип дата. Использую БСП. Мне необходимо сделать установку текущего параметра. При попытки сделать это "Попытка получения неинициализированного параметра". Иду дальше посмотрел как сделано в типовой конфигурации.
Процедура УстановкаПараметровСеанса(ИменаПараметровСеанса)
   
    // СтандартныеПодсистемы
    СтандартныеПодсистемыСервер.УстановкаПараметровСеанса(ИменаПараметровСеанса);
    // Конец СтандартныеПодсистемы
    УчетБилетовОбщий.УстановкаПараметровСеанса(ИменаПараметровСеанса);
КонецПроцедуры
////

Функция УстановкаПараметровСеанса(ИменаПараметровСеанса) Экспорт
    УстановленныеПараметры = Новый Массив;
    Если ИменаПараметровСеанса = Неопределено Тогда
        Возврат УстановленныеПараметры;
    КонецЕсли;
   
    Если ИменаПараметровСеанса.Найти("ТекущийПериод") <> Неопределено Тогда
        ПараметрыСеанса.ТекущийПериод  = ТекущаяДата();
        УстановленныеПараметры.Добавить("ТекущийПериод");
    КонецЕсли;
   
    Возврат УстановленныеПараметры;
       
КонецФункции
//
при попытки выполнить это ругается, на несоответствие типов. В обработчике в табло, на данный параметр пишет "ошибка чтения значения". Вобщем что я делаю не так??


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн NetWorm

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-02
  • Сайт: 
  • Профессия: Разработчик 1С
Ну вообще я и смотрел отладчиком. И такое происходит именно при использованиии БСП. И инициализация происходит как я понял где-то в недрах функции ПередНачаломСистемы(). Но сидел я до 3 ночи так и не отловил тот момент

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
запиши свой параметр в модуль сеанса и "НЕ парься"... :)
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн NetWorm

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-02
  • Сайт: 
  • Профессия: Разработчик 1С
В том от и проблема, что он там тоже на пишет напрямую...
пишу ПараметрыСеанса.ТекущийПериод  = ТекущаяДата();
а он и не работает.. Происходит тоже счамое, что описывал выше

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(4)
Создал параметр сеанса "Текущий период" тип дата

а КАКОЙ у тебя "состав даты" ??
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн NetWorm

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-02
  • Сайт: 
  • Профессия: Разработчик 1С
Цитировать
а КАКОЙ у тебя "состав даты" ??


Пробовал разный пробовал и строку писать, ему всеравно


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4523
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6070
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4190
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8477
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8550
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal