Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как подчищять форму от данных ?  (Прочитано 1071 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Никитa

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-18
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите как подчистить форму, от данных?
В ПолеВвода выбираем значение, говорим сформировать отчет, отчет сформировывается (по выбранному значению), Жмем отчистить поле ввода, и занова сформировать отчет. И сформировывается какаето фигня. (При пустом поляВвода первый раз формируется полный список всех данных (это то что нам и нужно), но после очистки поляВвода формируется какаето ерунда)

КОД:
Перем КомпУчасток, КомпДом;

Процедура ПолеВвода1ПриИзменении(Элемент)
Если ПолеВвода1="" Тогда
Список=Новый Массив;
ЗначениеЗаполнено(0);
 
   Запрос = Новый Запрос;
Запрос.Текст =
"                        ВЫБРАТЬ
| СтруткутраПредприятия.Ссылка
|ИЗ
| Справочник.СтруткутраПредприятия КАК СтруткутраПредприятия";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Ссылка);
КонецЦикла;

КомпУчасток.Значение=Список;
КомпУчасток.Использование = Истина;


Иначе
КомпУчасток.Значение = ПолеВвода1;
    КомпУчасток.Использование = Истина;
КонецЕсли;

КонецПроцедуры


Процедура ПолеВвода27ПриИзменении(Элемент)


Если ПолеВвода27="" Тогда
    Список=Новый Массив;
ЗначениеЗаполнено(0);
 
   Запрос2 = Новый Запрос;
Запрос2.Текст =
"                        ВЫБРАТЬ
|Обращения.Адрес
|ИЗ
| РегистрНакопления.Обращения КАК Обращения  ";

Результат = Запрос2.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Ссылка);
КонецЦикла;

КомпУчасток.Значение=Список;
КомпУчасток.Использование = Истина;


Иначе

    КомпДом.Значение = ПолеВвода27;
    КомпДом.Использование = Истина;

КонецЕсли;


КонецПроцедуры

Процедура ПриОткрытии()
// Вставить содержимое обработчика.
КомпДом = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Дом"));
КомпУчасток = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Участок"));
//Участки=Справочники.СтруткутраПредприятия.Выбрать();


Список=Новый Массив;
Список.Очистить();
//Список.Участок= ПредопределенноеЗначение ("СправочникСсылка.СтруткутраПредприятия");
// ЗначениеЗаполнено("Участок");
Запрос = Новый Запрос;

Запрос.Текст =
"                        ВЫБРАТЬ
| СтруткутраПредприятия.Ссылка
|ИЗ
| Справочник.СтруткутраПредприятия КАК СтруткутраПредприятия";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Ссылка);
КонецЦикла;

КомпУчасток.Значение=Список;
КомпУчасток.Использование = Истина;

        /////////////////////////////////////////////
Список2=Новый Массив;

Запрос2 = Новый Запрос;
Запрос2.Текст = "ВЫБРАТЬ
| Дома.Ссылка
|ИЗ
| Справочник.Дома КАК Дома";



Результат2 = Запрос2.Выполнить();
Выборка2 = Результат2.Выбрать();
Пока Выборка2.Следующий() Цикл
Список2.Добавить(Выборка2.Ссылка);
КонецЦикла;

КомпДом.Значение=Список2;
КомпДом.Использование = Истина;

//
//


КонецПроцедуры

Процедура ПолеВвода1Очистка(Элемент, СтандартнаяОбработка)

КонецПроцедуры

Процедура ПолеВвода27Очистка(Элемент, СтандартнаяОбработка)
КонецПроцедуры


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПолеВвода27Очистка(Элемент, СтандартнаяОбработка)
    Поле27 = "";
КонецПроцедуры
Добавлено: 11 Мар 2014, 11:06

http://russkiy-na-5.ru/rules/12

Последний раз редактировалось: KrivosheevEV; 11 Мар 2014, 11:06. Причина: Объединение сообщений

Оффлайн Никитa

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-18
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ПолеВвода27Очистка(Элемент, СтандартнаяОбработка)
    Поле27 = "";
КонецПроцедуры
Добавлено: 11 Мар 2014, 11:06

http://russkiy-na-5.ru/rules/12
Спасибо! Сделал так
Процедура ПолеВвода1ПриИзменении(Элемент)
Если НЕ ЗначениеЗаполнено(ПолеВвода1) Тогда
Список=Новый Массив;   
   Запрос = Новый Запрос;
Запрос.Текст =
"                        ВЫБРАТЬ
| СтруткутраПредприятия.Ссылка
|ИЗ
| Справочник.СтруткутраПредприятия КАК СтруткутраПредприятия";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Ссылка);
КонецЦикла;

КомпУчасток.Значение=Список;
КомпУчасток.Использование = Истина;


Иначе
КомпУчасток.Значение = ПолеВвода1;
    КомпУчасток.Использование = Истина;
КонецЕсли;

КонецПроцедуры


Процедура ПолеВвода27ПриИзменении(Элемент)
Если НЕ ЗначениеЗаполнено(ПолеВвода27) Тогда
    Список=Новый Массив;
  Запрос2 = Новый Запрос;
Запрос2.Текст = "ВЫБРАТЬ
| Дома.Ссылка
|ИЗ
| Справочник.Дома КАК Дома";


Результат = Запрос2.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Ссылка);
КонецЦикла;

КомпДом.Значение=Список;
КомпДом.Использование = Истина;


Иначе

    КомпДом.Значение = ПолеВвода27;
    КомпДом.Использование = Истина;

КонецЕсли;


КонецПроцедуры
Сейчас новая проблемка :) как осуществить отбор в интервале дат с чч.мм.гггг по чч.мм.гггг ?:dfbbdrfb:

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Не, мне тоже лениво думать.


 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7448
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3888
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2122
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7354
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6962
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 1
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal