Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 13:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с отчетом По ДО за период  (Прочитано 991 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Serge_ASB

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Программист 8.1
Платформа 7.7 7.70.027
конфа БухУчет 4.5 7.70.515


Ситуация следующая:
Организация перекроила план счетов сл. образом:
20 - ОСНОВНОЕ ПРОИЗВОДСТВО
23-ВСПОМОГАТЕЛЬНОЕ ПРОИЗВОДСТВО
25 -ОБЩЕПРОИЗВОДСТВЕННЫЕ РАСХОДЫ
26-ОБЩЕХОЗЯЙСТВЕННЫЕ РАСХОДЫ
29-ОБСЛУЖИВАЮЩЕЕ ПРОИЗВОДСТВО
Субконто у всех одинаковые:
1 - СтатьиЗатратНаПроизводство (Справочник)
2 - Подразделения (Справочник)
Требуется отчет, за период, который бы выводил Дебетовые обороты.
Принцип следующий


для каждого Эл из СтатьиЗатратНаПроизводство
перебор счетов (из верхнего списка)
 для каждого Эл из Подразделения
   Получить сумму ДО (период, Счет, Ск1,Ск2)

Получится длиннючая таблица.
Выводит суммы по ДО неверно, вернее, параметры в ДО поставить не дает.
Эскиз прилагаю.
Заранее извиняюсь (если "чего не так")
   ИтМХ            = СоздатьОбъект("БухгалтерскиеИтоги");

   ИтПоСчету        = СоздатьОбъект("БухгалтерскиеИтоги");
   ИтПодр    = СоздатьОбъект("БухгалтерскиеИтоги");
   
   Счета=СоздатьОбъект("СписокЗначений");
   Счета.ДобавитьЗначение(СчетПоКоду("20"));
   Счета.ДобавитьЗначение(СчетПоКоду("23"));
   Счета.ДобавитьЗначение(СчетПоКоду("25"));
   Счета.ДобавитьЗначение(СчетПоКоду("26"));
   Счета.ДобавитьЗначение(СчетПоКоду("29"));   
   
   //////////////////////////////////////////////////////
   ИтПоСчету.ВключатьСубсчета(, 1);
   
   //////////////////////////////////////////////////////
   Таб.ВывестиСекцию("Заголовок");
   Таб.Вывестисекцию("Шапка");
   //СформироватьШапкуИтог(ИтПоСчету, Таб, "Шапка");
   //Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
   //////////////////////////////////////////////////////


   СпрСтатьи=СоздатьОбъект("Справочник.СтатьиЗатратНаПроизводство");
   
   СпрСтатьи.ВыбратьЭлементы();
   Пока СпрСтатьи.ПолучитьЭлемент() = 1 Цикл
      
      СтатьяЗатрат=СпрСтатьи.Наименование;
      Таб.ВывестиСекцию("Статья");
      для а =1 по Счета.РазмерСписка() Цикл
         Сч=Счета.ПолучитьЗначение(а);
         Таб.ВывестиСекцию("Счет");
      
         ИтПоСчету.ИспользоватьСубконто(ВидыСубконто.СтатьиЗатратНаПроизводство,); //СпрСтатьи,1
         ИтПоСчету.ИспользоватьСубконто(ВидыСубконто.Подразделения);   
         ИтПоСчету.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, );//Счета,,,1
         
         ИтПоСчету.ВыбратьСубконто(1);
         
         Пока ИтПоСчету.ПолучитьСубконто(1) = 1 цикл
            
              
            ИтПоСчету.ВыбратьСубконто(2);
            Пока ИтПоСчету.ПолучитьСубконто(2) = 1 цикл
               
               //ИтПодр.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, Сч);
               
               Деб = ИтПоСчету.ДО();//ИтПодр.ДО();// Сч,,,СпрСтатьи,ИтПоСчету.Субконто(1)
               Подразделение=ИтПоСчету.Субконто(1);
               Таб.ВывестиСекцию("Субконто2");
               
            КонецЦикла;
            //
         КонецЦикла;
      конецЦикла;   
   
      
      
   КонецЦикла;
   


   
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать","");


Оффлайн Кошки рулят

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-01-07
  • Сайт: 
Убрать всякие верхние списки, сделать нормальный запрос и обойти его


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
24 Сообщений
BuhRust
21 Сообщений
alexandr_ll
20 Сообщений

* Кто онлайн

  • Точка Гостей: 817
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal