Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не отображается картинка  (Прочитано 2470 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствйуте. Обычная форма. Есть справочник. Реквизиты Каталог(строка), ХрЗнч(ХранилищеЗначения). Реквизит на форме Данные(произвольный тип).
В модуле формы такой код.
Процедура Кнопка1Нажатие(Элемент)
    ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбораФайла.ПолноеИмяФайла = "";
    Текст = "ru = ""Текст""; en = ""Text""";
    ДиалогВыбораФайла.МножественныйВыбор = Ложь;
    ДиалогВыбораФайла.Заголовок = "Выберите файл";
    Если ДиалогВыбораФайла.Выбрать() Тогда
        ИмяФайла = ДиалогВыбораФайла.ПолноеИмяФайла;
        Картинка = Новый ДвоичныеДанные(ИмяФайла);
        Данные = Картинка;
        Каталог = ПоместитьВоВременноеХранилище(Картинка);
        Модифицированность = Истина;
        КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    Если Данные <> Неопределено Тогда
        ХранилищеКартинки = Новый ХранилищеЗначения(Данные, Новый СжатиеДанных());
        ЭтаФорма.ХрЗнач = ХранилищеКартинки;
    КонецЕсли;
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
 Каталог = ПолучитьНавигационнуюСсылку(ЭтаФорма.Ссылка, "ХрЗнч");   
КонецПроцедуры
Не знаю как отобразить картинку на форме. На форме есть поле картинки, но ничего не отображается..


Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Насколько я поняла, проблема в том, что в обычных формах не отрабатывает момент
Каталог = ПоместитьВоВременноеХранилище(Картинка);
Я смотрела в управляемых если на форму вынести реквизит с типом "строка", который будет содержать  адрес временного хранилища, то форма сможет отобразить сами графические данные.
В обычных я не могу создать поле картинки и привязать к нему строковый реквизит с адресом..


Теги:
 

Пункт меню "Таблица" не отображается

Автор FlyerCyberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3668
Последний ответ 05 Мар 2012, 22:27
от FlyerCyber
Отображается не весь стаж для сотрудника в печатной форме СЗВ-СТАЖ (ЗУП 3.1.2.238)

Автор Psm_2015Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1458
Последний ответ 30 Май 2017, 04:10
от Psm_2015
Некорректно отображается печатная форма счета нового счета фактуры

Автор blue_stormРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 6142
Последний ответ 01 Фев 2012, 17:29
от blue_storm
Отчет "Выручка мастеров" не отображается в режиме 1С:Предприятие, что забыл?

Автор nartanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3078
Последний ответ 26 Фев 2015, 21:40
от vitasw
СКД. Надпись "Отчет формируется" и картинка при формировании отчета

Автор AssemblerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 9935
Последний ответ 13 Сен 2011, 18:18
от Assembler

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 119
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal