Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 22:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание внешнего отчета в СКД  (Прочитано 7049 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Создала отчет в СКД (материальный отчет). Проблема в том, что при запуске отчета используется стандартная форма настройки, но только не та, что я установила (она управляемая может в этом дело, вызвать ее через кнопку не могу, само приложение - обычное).
Хочу формата как на рисунке, но изобразить подобное в простой форме умишка не хватает.
Может кто подскажет как вызвать эту форму, либо как в обычной форме что-то подобное изобразить


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
включите в свойстах конфигурации флаг - использовать управляемые формы в обычном приложении, или рисуйте обычную форму для отчета

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Так в том-то и дело, что в приложении я создаю и использую управляемую форму, но мне нужно этот отчет сделать внешним

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
сохраняйте этот отчет как внешний и загружайте в БД

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Данный отчет нормально работает с управляемыми формами из базы, однако при сохранении его как внешнего используются стандартные формы, но не те, что были созданы мной

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Данный отчет нормально работает с управляемыми формами из базы, однако при сохранении его как внешнего используются стандартные формы, но не те, что были созданы мной
а что вам мешает создать форму во внешней обработке?

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Ясно, в другой раз попробую. Уже конфигурацию вскрыла. Спасибо за совет

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Уже конфигурацию вскрыла

:o
Очень страшно спрашивать что это означает.

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
:D Не, ну серьезно нравиться СКД. Но с формами заморочки
Добавлено: 06 Мар 2014, 13:36

Как из формы передать значения в СКД?

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Как из формы передать значения в СКД?
Процедура УстановитьПараметр(НаименованиеПараметра, ЗначениеПараметра) ЭКСПОРТ					
Настройки = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
Для Каждого Параметр Из Настройки Цикл
Если Тип(Параметр) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда
Если Параметр.Параметр = Новый ПараметрКомпоновкиДанных(НаименованиеПараметра) Тогда
Параметр.Значение = ЗначениеПараметра;
Параметр.Использование = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры // УстановитьПараметр()
               


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7062
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2998
Последний ответ 27 Май 2015, 10:02
от casper009
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4490
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4099
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1960
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal