Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 01:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Re: 1с 7.7 Склад Ошибка  (Прочитано 931 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн antoha86

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-12
  • Сайт: 
  • Профессия: Ученик 1С
Помогите пожалуйста, отчет не выводит запрос с регистра Партии товаров, ошибок не выдает

Текст модуля:
Перем КолГруппировок, Таб;
Процедура ПриОткрытии()
   СЗ.ДобавитьЗначение("Номенклатура");
   СЗ.ДобавитьЗначение("Контрагент");   
КонецПроцедуры

Процедура СдвинутьЗначение ()
   Если СЗ.ТекущаяСтрока()=1 Тогда
      СЗ.СдвинутьЗначение(1, СЗ.ТекущаяСтрока());
   Иначе
      СЗ.СдвинутьЗначение(-1,СЗ.ТекущаяСтрока());
   КонецЕсли;
КонецПроцедуры 
Процедура СформироватьТаблицу(Запрос, НомГруппировки)   
   Отступ="";
   нн=0;
   Если НомГруппировки<>1 Тогда
      Для КолСимвТабуляции=1 По НомГруппировки Цикл
         Отступ=Отступ+"  ";
      КонецЦикла;
   КонецЕсли;
   Пока Запрос.Группировка(НомГруппировки)=1 Цикл
      Значение=Отступ+Запрос.ЗначениеУпорядочивания(НомГруппировки);
      Сумма=Запрос.Сумма;
      Если Запрос.Номенклатура.ЭтоГруппа()=1 Тогда
         Таб.ВывестиСекцию("Группа");
      Иначе
         нн=нн+1;
         Таб.ВывестиСекцию("Строка");
      КонецЕсли;
      Если НомГруппировки <> КолГруппировок Тогда
         СформироватьТаблицу(Запрос, НомГруппировки+1);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры

Процедура Сформировать()
   Таб=СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   Таб.ВывестиСекцию("Шапка");
   Запрос=СоздатьОбъект("Запрос");
   
   ТекстЗапроса=
   "//((ЗАПРОС(Запрос1)
   |Период с НачДата по КонДата;
   |Номенклатура=Регистр.Прибыль.Номенклатура;
   |Контрагент=Регистр.Прибыль.Контрагент;
   |Сумма=Регистр.Прибыль.Сумма;
   |Партия=Регистр.ПартииТоваров.Партия;
   |Функция Прибыль=Сумма(Сумма);";
   
   КолГруппировок=0;
   Для Ном=1 По СЗ.РазмерСписка() Цикл
      Если СЗ.Пометка(Ном)=1 Тогда
         ТекстЗапроса=ТекстЗапроса+"
         |Группировка "+ СЗ.ПолучитьЗначение(Ном)+";"; //СЗ.ПолучитьЗначение(Ном);"
         КолГруппировок=КолГруппировок+1;
      КонецЕсли;
   КонецЦикла;
   Если КолГруппировок = 0 Тогда
      Предупреждение("Нельзя построить отчет без группировок!",60);
      Возврат;
   КонецЕсли;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;
   СформироватьТаблицу(Запрос,1);
   Таб.ТолькоПросмотр(1);
   Таб.Опции(0,0,0,0);
   Таб.Показать("");
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal