Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите подправить отчет  (Прочитано 1634 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Agla

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-11
  • Сайт: 
  • Профессия: Программист 1С
Есть отчет по продажам по месяцам в 1С 7.7 типовая бузгалтерия
1)отчет выводится , а месяц пишется как цифра, а нужно как название,
2)данные выводятся в столбец, а нужно слева товар, а справа по месяцам количество с суммой.


Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.

Оффлайн Agla

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-11
  • Сайт: 
  • Профессия: Программист 1С
1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.
2. следующие месяца выводятся вниз как столбец, а нужно напротив товара вправо
Добавлено: 27 Фев 2014, 14:31

1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.
2. следующие месяца выводятся вниз как столбец, а нужно напротив товара вправо
c 1 пунктом не получается незнаю в какое место дописать.

Последний раз редактировалось: Agla; 27 Фев 2014, 14:31. Причина: Объединение сообщений

Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
1.       
Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;
2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.

Оффлайн Agla

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-11
  • Сайт: 
  • Профессия: Программист 1С
1.       
Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;
2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.
Добавлено: 28 Фев 2014, 16:07

1.       
Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;
2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.
Вставив Ваш код все равно не выводит название месяца.

Последний раз редактировалось: Agla; 28 Фев 2014, 16:07. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal