Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор файлов в списке формы  (Прочитано 2116 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн qpluckq

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-26
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте, не получается выполнить отбор файлов через справочник, которые были прикреплены к определенному документу

Делал через произвольный запрос и вызов списка из формы документа
Код на кнопке в документе, должен открывать форму списка и передавать параметр "ФильтрФайлов"

 &НаКлиенте
Процедура ОткрытьФайл(Команда)

ФормаСписка =ПолучитьФорму("Справочник.ХранилищеФайлов.Форма.ФормаСпискаФайлов");
   ФормаСписка.ФильтрФайлов = Объект;
   ФормаСписка.Открыть();
КонецПроцедуры 

В справочнике в форме списка установлен произвольный запрос:

ВЫБРАТЬ
    ХранилищеФайлов.Наименование КАК Наименование
ИЗ
    Справочник.ХранилищеФайлов КАК ХранилищеФайлов
ГДЕ
    ХранилищеФайлов.Объект = &Объект

Так же в форме списка справочника код "ПриОткрытии"
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   СписокФайлов.Параметры.УстановитьЗначениеПараметра("Объект",ФильтрФайлов);
КонецПроцедуры

И у справочника есть реквизит "Объект" который является ссылкой на документ Заявки из которого запускаем форму справочника

Подскажите в чем ошибка, т.к. я начинающий не пойму как правильно передать параметр и собственно сделать чтобы отобранные файлы были = Объекту т.е. уникальной заявке (документу)

Ошибка выводится следующая:
{Справочник.ХранилищеФайлов.Форма.СписокФайлов.Форма(26,64)}: Переменная не определена (ФильтрФайлов)
   СписокФайлов.Параметры.УстановитьЗначениеПараметра("Объект",<<?>>ФильтрФайлов);


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
В вашем случае совершенно не нужно использовать метод ПолучитьФорму(), достаточно её просто открыть, передав нужный параметр.
&НаКлиенте
Процедура ОткрытьФайл(Команда)
   ПараметрФормы = Новый Структура("ФильтрФайлов", Объект);   //  очень неудачно вы выбрали имя переменной "Объект", странно, что платформа не выдала ошибку
   ОткрытьФорму("Справочник.ХранилищеФайлов.Форма.ФормаСпискаФайлов", ПараметрФормы)
КонецПроцедуры


В форме списка нужно использовать не ПриОткрытии(), а ПриСозданииНаСервере()
Процедура ПриСозданииНаСервере()
   СписокФайлов.Параметры.УстановитьЗначениеПараметра("Объект", Параметры.ФильтрФайлов);
КонецПроцедуры

Оффлайн qpluckq

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-26
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо большое, вроде заработало, но теперь ругается на запрос

{(9, 25)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
 неограниченной длины и поля несовместимых типов.
ХранилищеФайлов.Объект <<?>>= &Объект

Здесь сравнивается реквизит ссылка на документ с параметром, это не верно? подскажите как поступить?

и объект это не имя переменной, это ссылка на "Объект" который в форме документа

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Не зная структуры ваших метаданных, вряд ли смогу дать вменяемый ответ...
Добавлено: 26 Фев 2014, 21:41

>> это ссылка на "Объект" который в форме документа
Ну, я так и подозревал. Реквизит "Объект" в форме документа - это специальный тип данных формы (ДанныеФормыКоллекция). В вашем случае скорее всего нужно задавать в качестве параметра Объект.Ссылка
Но это - только предположение


Теги: 8.2 Список Отбор 
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 285
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4812
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3407
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4985
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 582
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 591
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal