Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 08:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка значений  (Прочитано 6224 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ChaFieLd

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2010-05-18
  • Сайт: 
Добрый день, Уважаемые!

Конфигурация не типовая, дописанная в ручную.
Проблема состоит в том, чтобы из справочника выбрать пустые значения. В ячейке находится ссылка, ссылаемая на другой справочник. перечитал уже множество форумов нигде не описывается как сделать подобную выборку! с текстом и числами работает прекрасно, а вот ссылки обрабатывать не хочет. Подскажите пожалуйста как быть!

Процедура Выполнить()   
Пер = СоздатьОбъект("Справочник.ОбъектыПотребителей");
Пер.ВыбратьЭлементы(0);
КолВсего = 0;
КолГотово = 0; 
Пока Пер.ПолучитьЭлемент() > 0 Цикл
Если Пер.ЭтоГруппа() = 0 Тогда
    КолВсего = КолВсего + 1;
Если ПустоеЗначение(Пер.Фидер) = 1 Тогда   
КолГотово = КолГотово + 1;   
КонецЕсли;
КонецЕсли;
КонецЦикла;
Сообщить("кол фидеров "+КолГотово+", всего "+КолВсего+" абонентов");
КонецПроцедуры

проблема возникает вот в этом месте

Если ПустоеЗначение(Пер.Фидер) = 1 Тогда 

Надеюсь на вашу помощь!


Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #1: 18 Май 2010, 10:21 »
а в отладчике что??? при остановке на элементе с пустой ссылкой??? Пер.Фидер =???

Оффлайн ChaFieLd

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2010-05-18
  • Сайт: 
Re: Выборка значений
« Ответ #2: 18 Май 2010, 10:41 »
а в отладчике что??? при остановке на элементе с пустой ссылкой??? Пер.Фидер =???

В отладчике все прекрасно проходит, никаких претензий с этому блоку нет, только выдает постоянно 0! он просто не ведет перебор нужного поля, я подозреваю что все дело в ссылке на другой справочник, так как с числами и строками всесчитет. вот ищу способ реализовать перебор ссылок!

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #3: 18 Май 2010, 11:13 »
ПустаяСтрока(СокрЛП(Строка(Пер.Фидер)))  - а если так

Оффлайн ChaFieLd

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2010-05-18
  • Сайт: 
Re: Выборка значений
« Ответ #4: 18 Май 2010, 11:23 »
К сожалению результатов не дало. Я так понимаю это все обработчики для ячеек типа строка или число. но выборка идет из другого справочника, быть можнт надо в условии оперировать с другим справочником?? уже 2 дня бьюсь над проблемой вроде все эллементарно а не работает. может быть есть еще варианты?

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #5: 18 Май 2010, 11:24 »
Пришли значение Пер.Фидер из отладчика при остановке на элементе с пустой ссылкой

Оффлайн ChaFieLd

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2010-05-18
  • Сайт: 
Re: Выборка значений
« Ответ #6: 18 Май 2010, 11:52 »
Может чтото я делаю не так но на табло просто пустая строка в точке останова на этом месте не пишет никаких сообщений абсолютно. строка
КолГотово = КолГотово + 1;  
игнорируется , значит условие не выполняется, но все равно табло пустое.

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #7: 18 Май 2010, 11:59 »
Пустая строка или пустая ссылка.......

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #8: 18 Май 2010, 12:00 »
- значение неопределенного типа - всегда пустое;
- значение типа ''строка'' проверяется как в методе ПустаяСтрока;
- значение типа ''число'' проверяется на равенство нулю;
- значение типа ''дата'' проверяется на пустое значение;
- значения следующих типов: ''справочник'', ''перечисление'', ''документ'', ''счет'', ''вид субконто'', ''план счетов'', ''календарь'' проверяются как в методах Выбран  для соответствующего типа объекта.;
- значение типа ''СписокЗначений'' считается пустым, если в нем нет значений;
- значение типа ''ТаблицаЗначений'' считается пустым, если нет ни одной строки таблицы.


Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Re: Выборка значений
« Ответ #9: 18 Май 2010, 12:01 »
можно ПолучитьПустоеЗначение этого типа и сравнить его со значением выборки!!!!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal