Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение реквизита "Наименование"  (Прочитано 3364 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alieramada

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
 <_< Доброй ночи.
Вопрос в следующем. Как можно сделать автоматическое заполнение реквизита "Наименование" справочника на основании состава табличной части?
Т.е есть справочник "Характеристики" номенклатуры, в нём есть табличная часть "Свойства Номенклатуры" в которой 2 реквизита:Свойство и значение.
Наименование характеристики должно формироваться автоматически из названий всех свойств, входящих в эту характеристику и их значений.
Пока додумался до этого
&НаКлиенте
Процедура ХарактеристикаПриИзменении(Элемент)
ТЧ=Объект.СвойстваНоменклактуры;
Для Каждого Строка из ТЧ Цикл
   Объект.Наименование=Строка.Свойство;
   Объект.Наименование=Объект.Наименование+Строка.Значение;
КонецЦикла
КонецПроцедуры
Однако, таким образом можно получить только последнюю запись.
И ещё, почему если написать
Объект.Наименование=Строка.Свойство+Строка.Значение;
Выдаётся ошибка о том, что преобразование к типу строка не может быть выполнено?


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
>> Однако, таким образом можно получить только последнюю запись.
Разумеется, ведь в вашем коде на каждом шаге цикла "Объект.Наименование" инициализируется по-новому.
&НаКлиенте
Процедура ХарактеристикаПриИзменении(Элемент)
   ТЧ=Объект.СвойстваНоменклактуры;
   ТекущееНаименование = "";
   Для Каждого Строка из ТЧ Цикл
      ТекущееНаименование = ТекущееНаименование + Строка.Свойство;
      ТекущееНаименование = ТекущееНаименование + Строка.Значение;
   КонецЦикла
   Объект.Наименование = ТекущееНаименование;
КонецПроцедуры

>> почему если написать ...выдаётся ошибка о том, что преобразование к типу строка не может быть выполнено?
В этом случае, скорее всего, "Строка.Свойство" является неопределённым (не заполнено), а Платформа не может преобразовать "Неопределено" в строку.
В общем случае складывать (правильно называть конкатенировать) строки, чтобы наверняка не получать такого рода ошибки, нужно так:
СтрокаОбщая = "" + переменная1 + переменная2;


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7578
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2534
Последний ответ 30 Ноя 2011, 07:10
от has
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 625
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1582
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 379
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal