Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Итоги в группировках простого отчета  (Прочитано 1426 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Проблема в том, что в отчете выводятся итоги сверху у детальных записей, а нужны только снизу. Как от них избавиться?
В запросе 2-е группировки: по ВидЗадолженности и  СчетРасчетов

ВыборкаПоВидуЗадолженности = РезультатКонтрагенты.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ВидЗадолженности");
   Если ВыборкаПоВидуЗадолженности.НайтиСледующий(Перечисления.ВидыЗадолженности.Дебиторская, "ВидЗадолженности") Тогда
      ПодвалТаблицыДт.Параметры.Заполнить(ВыборкаПоВидуЗадолженности);
      
      ВыборкаПоСчету = РезультатКонтрагенты.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "СчетРасчетов");
      Пока ВыборкаПоСчету.Следующий() Цикл
          ПодвалТаблицыДтПоСчету.Параметры.Заполнить(ВыборкаПоСчету);   
         
         ВыборкаПоКонтрагенту = ВыборкаПоСчету.Выбрать();
         Пока ВыборкаПоКонтрагенту.Следующий() Цикл
            СтрокаТаблицыДт.Параметры.Заполнить(ВыборкаПоКонтрагенту);
            СтрокаТаблицыДт.ВерхнийКолонтитул.Выводить = Ложь;
            СтрокаТаблицыДт.Параметры.КонтрагентПредставление = ?(ПустаяСтрока(ВыборкаПоКонтрагенту.КонтрагентНаименованиеПолное),
               ВыборкаПоКонтрагенту.КонтрагентНаименование, ВыборкаПоКонтрагенту.КонтрагентНаименованиеПолное);
            ТабДокумент.Вывести(СтрокаТаблицыДт);
         КонецЦикла;
         
         ТабДокумент.Вывести(ПодвалТаблицыДтПоСчету);
      КонецЦикла;
   КонецЕсли;


Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
Помогите же кто-нибудь!!!! ХЕЛП

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
см. скрин, только у вас строка сверху (группировка) останется без итогов, и внизу появится строка с итогами,
а чем этот вариант не устраивает?

Оффлайн Татьяна_В

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Разработчик 1С
см. скрин, только у вас строка сверху (группировка) останется без итогов, и внизу появится строка с итогами,
а чем этот вариант не устраивает?

Эт понятно. Я тоже всегда СКД пользовалась. А тут заполнение макета через модуль объекта. Может на самом деле переделаю на СКД. Спасибо


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7063
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3000
Последний ответ 27 Май 2015, 10:02
от casper009
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4099
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3878
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1961
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal