Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Мая 2021, 19:56
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: На что влияет значение "максимальная сумма кредита покупателю"?  (Прочитано 5787 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vlad23

  • *
  • Регистрация: 2010-05-13
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
Конфигурация "Торговля и склад" или "Комплексная".
В справочнике "Контрагенты" в закладке "Кредиты" можна задать максимальную сумму кредита покупателю, но на что влияет установленное значение понять трудно. Установил значение 100 для определенного контрагента. При этом безболезненно проводятся расходные накладные (товар) по товарному кредиту на любую сумму этому клиенту? Логично было бы, чтобы при привышении заданной суммы был запрет на продажу в кредит данному контрагенту ...


Оффлайн Myti

  • *****
  • Регистрация: 2009-10-12
  • Сообщений: 678
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Функция КонтрольКредитаПройден(ВремПокупатели)
   
   
   РазрешитьПревышениеКредита = глПолучитьПолномочие("РазрешитьПревышениеКредита");
   
   // Проверим дату оплаты
   КонтрольДатыОплаты = КонтрольДатыОплаты();
   Если ПустоеЗначение(КонтрольДатыОплаты) = 0 Тогда
       Если РазрешитьПревышениеКредита <> 0  Тогда
         глСообщениеПроведения(КонтрольДатыОплаты+ РазделительСтрок+
         "Документ: "+глПредставлениеДокумента(ТекущийДокумент()), ТекущийДокумент());
      Иначе                   
         глНеПроводить(Контекст,КонтрольДатыОплаты);
         Возврат 0;
      КонецЕсли;
   КонецЕсли;         
   
   Если Договор.НеКонтролироватьКредит = 1 Тогда
      Возврат 1;
   КонецЕсли;
   
   ТекущийДолг = ВремПокупатели.СводныйОстаток(Фирма,Договор,,,,"СуммаВал");
   
   Если (ТекущийДолг + СуммаВзаиморасчетов) > (Договор.СуммаКредита) Тогда
                                                           
      ВалютаКредита = Договор.ВалютаВзаиморасчетов;
      
      СтрокаСообщ = "Сумма накладной вместе с текущим долгом превышает сумму максимального кредита клиенту!
                 |   Текущий долг:   "+глФРМ(ТекущийДолг,ВалютаКредита)+"
                 |   Остаток кредита:"+глФРМ(Договор.СуммаКредита - ТекущийДолг,ВалютаКредита)+"
                 |   Сумма накладной:"+ глФРМ(СуммаВзаиморасчетов,ВалютаКредита)+"!";
      
       Если РазрешитьПревышениеКредита <> 0  Тогда
         глСообщениеПроведения(СтрокаСообщ+ РазделительСтрок+
         "Документ: "+глПредставлениеДокумента(ТекущийДокумент()), ТекущийДокумент());
         Возврат 1;
      Иначе                   
         глНеПроводить(Контекст,СтрокаСообщ);
         Возврат 0;
      КонецЕсли;
   КонецЕсли;
   
   Возврат 1;
   
КонецФункции // КонтрольКредитаПройден()

Оффлайн Vlad23

  • *
  • Регистрация: 2010-05-13
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
Спасибо за помощь, но у меня конфигурации Украины. В ней кредит ведется по контрагентам, а не по договорам ... Данной процедуры я не нашел ...

Оффлайн Myti

  • *****
  • Регистрация: 2009-10-12
  • Сообщений: 678
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Тык.,....сделайте поиск по всей конфигурации по строке "СуммаКредита" там и смотрите на фто влияет


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
34 Сообщений
kiokiosan
18 Сообщений
alexandr_ll
13 Сообщений
DmitriyF DmitriyF
11 Сообщений
antoneus antoneus
9 Сообщений
Ивашка
9 Сообщений
Мария2021
9 Сообщений
alex0402 alex0402
8 Сообщений
kah
8 Сообщений

* Кто онлайн

  • Точка Гостей: 299
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск