Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Два макета СКД  (Прочитано 3395 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hamec

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-12
  • Сайт: 
  • Профессия: Программист 1С
Всем доброго времени суток. Прошу помощи, перерыл все, что можно.

Задача, есть типовой отчет в УТ 11 "ВедомостьПоТоварамНаСкладах", есть 2 схемы СКД (отличаются запросами), соответственно, я хочу менять схему СКД в зависимости от параметра установленного на форме, схемы должны меняться до формирования отчета, чтобы пользователь мог его кастамизировать. Делаю так

&НаКлиенте
Процедура ВыводитьНулевыеПриИзменении(Элемент)
СменитьСКД();
КонецПроцедуры

&НаСервере
Процедура СменитьСКД()
ОтчетОбъект = РеквизитФормыВЗначение("Отчет");

Если ВыводитьНулевые Тогда
СхемаКомпоновкиДанных = ОтчетОбъект.ПолучитьМакет("СхемаКомпоновкиДанныхНулевая");
Иначе
СхемаКомпоновкиДанных = ОтчетОбъект.ПолучитьМакет("СхемаКомпоновкиДанныхБезНулей");
КонецЕсли;

ОтчетОбъект.СхемаКомпоновкиДанных = СхемаКомпоновкиДанных;
ОтчетОбъект.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
ОтчетОбъект.КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;

ЗначениеВРеквизитФормы(ОтчетОбъект,"Отчет");
КонецПроцедуры

Но схема не меняется, если из отчета убрать Основную СКД, то отчет вообще перестает работать. Прошу помочь, уже третий день бьюсь


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Два макета СКД
« Ответ #1: 21 Фев 2014, 13:31 »
Модуль объекта -  Процедура ПриКомпоновкеРезультата()
Там смотри.

Оффлайн hamec

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-12
  • Сайт: 
  • Профессия: Программист 1С
Re: Два макета СКД
« Ответ #2: 24 Фев 2014, 12:17 »
Эта же процедура выполняется после того, как запущено формирование отчета, а хотелось бы, чтобы до, чтобы выводились все параметры и т.п.

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Два макета СКД
« Ответ #3: 25 Фев 2014, 10:24 »
Тогда удобнее сделать один СКД отчёт с двумя необходимыми вариантами.

Оффлайн hamec

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-12
  • Сайт: 
  • Профессия: Программист 1С
Re: Два макета СКД
« Ответ #4: 25 Фев 2014, 11:34 »
Так дело в том, что запросы разные


Теги: скд макет отчет 
 

Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3605
Последний ответ 21 Авг 2014, 17:51
от spikee666
Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 961
Последний ответ 01 Мар 2016, 14:33
от sveta C
??? Нет макета печатных форм "Заказ клиента" (для редактирования) УТ11

Автор Albert51rusРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3051
Последний ответ 28 Ноя 2011, 12:58
от AntonB
Можно ли получить префикс документа при "пользовательском" редактировании макета в БП 3.0?

Автор kornilov_rvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4388
Последний ответ 21 Фев 2014, 14:33
от MuI_I_Ika
Внешняя Печатная Форма. Выбор шапки макета по варианту склада.

Автор shustrikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1550
Последний ответ 13 Сен 2010, 09:01
от shustrik

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 249
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal