Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 07:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Зполнение табличной части документа по кнопке  (Прочитано 1537 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Заполнить(Команда)
Запрос = Новый Запрос;
Запрос.Текст =
                 "ВЫБРАТЬ
                 | ДанныеОСотрудникеСКурса.ФИО,
                 | ДанныеОСотрудникеСКурса.Должность,
                 | ДанныеОСотрудникеСКурса.Отдел,
                 | ДанныеОСотрудникеСКурса.Курс,
                 | ДанныеОСотрудникеСКурса.Статус
                 |ИЗ
                 | РегистрСведений.ДанныеОСотрудникеСКурса КАК ДанныеОСотрудникеСКурса
                 | ЛЕВОЕ СОЕДИНЕНИЕ Перечисление.ВидыОбучения КАК ВидыОбучения
                 | ПО ДанныеОСотрудникеСКурса.Статус = ВидыОбучения.Ссылка";
 Результат = Запрос.Выполнить();
 ВыборкаДетальныеЗаписи = Результат.Выбрать();
 Пока ВыборкаДетальныеЗАписи.Следующий() Цикл
КонецЦикла;
КонецПроцедуры


Никогда с табличной частью дело не имел, для меня это сложно и не совсем понятно, помогите с процедурой,

Последний раз редактировалось: MuI_I_Ika; 20 Фев 2014, 10:13


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
посмотри в синтаксис помошнике описание объекта ТабличнаяЧасть, его свойств и методов.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
посмотри в синтаксис помошнике описание объекта ТабличнаяЧасть, его свойств и методов.
спасибо, а как заполнить таб часть из данных запроса, что после запроса прописывать?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6650
  • РЕПУТАЦИЯ: 787
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Пока ВыборкаДетальныеЗАписи.Следующий() Цикл
    НоваяСтрока = ИмяТабличнойЧасти.Добавить();
    ЗаполнитьЗначения(НоваяСтрока,ВыборкаДетальныеЗАписи);
КонецЦикла
;

Оффлайн Luzer1C

  • ****
  • Сообщений: 455
  • РЕПУТАЦИЯ: 56
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
На управляемом приложении данный код работать не будет.
Надо эту процедуру прописывать с директивой &НаСервере. И вызывать отдельно. Кнопке "Заполнить табличную часть" назначить команду.
&НаКлиенте
Процедура Заполнить(Команда)
ТЗ = ПолучитьТЗ();
Для каждого СтрТЗ Из ТЗ Цикл
СтрДок = ТаличнаяЧасть.Добавить();
КонецЦикла;
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПолучитьТЗ()
Запрос = Новый Запрос;
Запрос.Текст =
                 "ВЫБРАТЬ
                 |   ДанныеОСотрудникеСКурса.ФИО,
                 |   ДанныеОСотрудникеСКурса.Должность,
                 |   ДанныеОСотрудникеСКурса.Отдел,
                 |   ДанныеОСотрудникеСКурса.Курс,
                 |   ДанныеОСотрудникеСКурса.Статус
                 |ИЗ
                 |   РегистрСведений.ДанныеОСотрудникеСКурса КАК ДанныеОСотрудникеСКурса
                 |      ЛЕВОЕ СОЕДИНЕНИЕ Перечисление.ВидыОбучения КАК ВидыОбучения
                 |      ПО ДанныеОСотрудникеСКурса.Статус = ВидыОбучения.Ссылка";
 Результат = Запрос.Выполнить();
 ТЗ = Результат.Выгрузить();
КонецПроцедуры
Халамбалам.

Последний раз редактировалось: Luzer1C; 20 Фев 2014, 10:51. Причина: Добавил пояснение


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4861
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8277
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5532
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10317
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7846
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 158
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal