Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Мая 2021, 02:09
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Взять значение из колонки по её названию  (Прочитано 7489 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grumax

  • *
  • Регистрация: 2010-04-27
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
Есть табличная часть, подразумевается что столбцу "А" соответствует столбец "сА"(формула) и "бА"(булево). Идея такая в столбце "А" храниться значение, в столбце "сА" формула, по которой это значение вычисляется, в столбце "бА" маячок, чтобы при сылке на данную ячейку, не пересчитывать формулу повторно...

Пока делаю инетрфейс, смысл как в Excel'е, перемещаясь по ячейкам видеть строку формулы.
Процедура ТабНормКартаПриАктивизацииЯчейки(Элемент)
      // Создаю переменные
      Перем сИмя, Строка, НайденнаяСтрока, ТекущийСтолбецФормулы ;
      // Создаю таблицу значений соответствия одной колонки другой
      табСоответствие = Новый ТаблицаЗначений ;
      табСоответствие.Колонки.Добавить("Мама", ОписаниеТиповС, "Мама") ;
      табСоответствие.Колонки.Добавить("Доча", ОписаниеТиповС, "Доча") ;
      // Заполняю таблицу данными
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "А" ;
      Строка.Доча = "сА" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Б" ;
      Строка.Доча = "сБ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Г" ;
      Строка.Доча = "сГ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Д" ;
      Строка.Доча = "сД" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Е" ;
      Строка.Доча = "сЕ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Ж" ;
      Строка.Доча = "сЖ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "З" ;
      Строка.Доча = "сЗ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "И" ;
      Строка.Доча = "сИ" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "К" ;
      Строка.Доча = "сК" ;
      Строка = табСоответствие.Добавить() ;
      Строка.Мама = "Л" ;
      Строка.Доча = "сЛ" ;
      // Запоминаем имя текущего столбца
      сИмя = ЭтаФорма.ЭлементыФормы.ТабНормКарта.ТекущаяКолонка.Имя ;
      // Ищем имя текущего столбца в нашей таблице
      НайденнаяСтрока = табСоответствие.Найти(сИмя, "Мама") ;
      Если НайденнаяСтрока = Неопределено Тогда
            Предупреждение("Столбец не найден!") ;     
      Иначе
            // Нашли название столбца в котором храниться формула для текущего
            ТекущийСтолбецФормулы = НайденаяСтрока.Доча ;
            // Выводим значение из найденого столбца в Поле Редактирования
            // ТУТ ЗАТЫК!!!!!
      КонецЕсли ;
     
КонецПроцедуры
Вроде как название столбца определил, на строке стою, как вывести значение в "Поле ввода" ума не хватает. Спасибо!


Slin
  • Гость
Просто присваиваешь значение полю....
Или свойству Значение

Оффлайн Grumax

  • *
  • Регистрация: 2010-04-27
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
Как это выглядит в коде?

Slin
  • Гость
Примерно так:
Процедура ТоварыПриАктивизацииЯчейки(Элемент)

Строка = ЭлементыФормы.Товары.ТекущаяСтрока;
Колонка = ЭлементыФормы.Товары.ТекущаяКолонка;
Если Колонка.Имя = "Номенклатура" Тогда
Строка[Колонка.Имя] = Справочники.Номенклатура.ПустаяСсылка();
КонецЕсли;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
LexaK
29 Сообщений
kiokiosan
18 Сообщений
alexandr_ll
16 Сообщений
Ивашка
12 Сообщений
kah
11 Сообщений
alex0402 alex0402
9 Сообщений
DmitriyF DmitriyF
9 Сообщений
antoneus antoneus
9 Сообщений
nvj84
7 Сообщений

* Кто онлайн

  • Точка Гостей: 99
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск