Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Тип не определен  (Прочитано 8906 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн fagust19821

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-15
  • Сайт: 
  • Профессия: Программист 1С
{Обработка.Тест.Форма.Форма.Форма(6,31)}: Тип не определен (ДиалогВыбораФайла)
      ДиалогОткрытияФайла = Новый <<?>>ДиалогВыбораФайла(Режим);
Мобильное приложение содержит синтаксические ошибки.
не могу понять почему эта ошибка
&НаКлиенте
Процедура Загрузить(Команда)
   Если  ПодключитьРасширениеРаботыСФайлами() Тогда
      Режим = РежимДиалогаВыбораФайла.Открытие;
      ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
      ДиалогОткрытияФайла.ПолноеИмяФайла = "";
      Фильтр = "Таблица(*.xls)|*.xls";
      ДиалогОткрытияФайла.Фильтр               = Фильтр;
      ДиалогОткрытияФайла.МножественныйВыбор   = Ложь;
      ДиалогОткрытияФайла.Заголовок            = "Выберите файл c описью вложения";
      
      Если ДиалогОткрытияФайла.Выбрать() Тогда
         ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
      Иначе
         Возврат;
      КонецЕсли;
      
      Попытка
         Excel = Новый COMОбъект("Excel.Application");
         Excel.WorkBooks.Open(ПутьКФайлу);
         ExcelЛист = Excel.Sheets(1);
      Исключение
         Сообщить("Ошибка открытия файла!");
         Возврат;
      КонецПопытки;
      
      ТекущаяСтрока = 1;
      ЧитатьПо=ExcelЛист.Usedrange.Rows.Count;   КонецЕсли;
   ТекущаяСтрока = 1;

   ЧитатьПо=ExcelЛист.Usedrange.Rows.Count;
      Для н=ТекущаяСтрока по ЧитатьПо Цикл
         А=1; В=2;
         Элементы.Тест.ДобавитьСтроку();
         Элементы.Тест.ТекущиеДанные.Вопрос=А;
         Элементы.Тест.ТекущиеДанные.Ответ=В;
         Элементы.Тест.ТекущиеДанные.Вопрос=" "+сокрЛП(ExcelЛист.Cells(н,1).Value);
         Элементы.Тест.ТекущиеДанные.Ответ=" "+сокрЛП(ExcelЛист.Cells(н,2).Value);
         КонецЦикла;
КонецПроцедуры



Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Re: Тип не определен
« Ответ #1: 17 Фев 2014, 09:33 »
ДиалогВыбораФайла
Описание:

Предназначен для работы с диалогом специального вида для открытия файла или нескольких файлов, сохранения файла или выбора каталога.
Для работы метода в режиме запуска "Веб-клиент", необходимо предварительно подключить расширение работы с файлами.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн belu

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2014-02-07
  • Сайт: 
Re: Тип не определен
« Ответ #2: 17 Фев 2014, 10:56 »
Да :( работает везде кроме мобильного приложения. Может в мобильном это вообще не работает :dfbsdfbsdf:
Добавлено: 17 Фев 2014, 10:59

Есть такая статья: http://katalog.forum-1c.ru/public/155226/
Не стал её читать, ключевое в ней вот это:

Беглое изучение справки дало неутешительный результат - на мобильной платформе не поддерживается "ДиалогВыбораФайла".


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 225
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal