Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Возврат поставщику  (Прочитано 3342 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Возвращаем тару. Выбираю Документы-Учет материалов-Отргузка материалов на сторону и там ставлю галку возврат поставщику. Заполняю, но при проведении выдает ошибку "Выбранный счет является группой!(проводка 1, счет 62.0)". Подскажите как надо проводки сделать, пожалуйста. Выкладываю кусочки кода из модуля, касаемые возврата.

1)   
ИначеЕсли ДокументПоступления.Выбран()=1 тогда  // возврат поставщику
СчПоставщика = ?(ДокументПоступления.ВидПоставщика = Перечисление.ВидПоставщика.Поставщики,
                 СчПоставщика,СчетПоКоду( "76.1" ));
КонецЕсли;
//
Если (ВидОтгрузки=1) И (ИтогНДС<>0)  Тогда // возврат поставщику
Операция.НоваяПроводка();
Операция.НомерЖурнала = "МТ";
Операция.СодержаниеПроводки = "Возврат НДС";
Операция.Кредит.Счет = СчетПоКоду("18.3");
Операция.Кредит.Субконто(1,Получатель);
Операция.Дебет.Счет = СчПоставщика;
Операция.Дебет.Субконто(1,Получатель);
Операция.Дебет.Субконто(2,Договор);
Если СчПоставщика = СчетПоКоду("62.8") тогда
Операция.Дебет.ВидыРеализацииМатериалов = ВидРеализации;
КонецЕсли;

Операция.Сумма = ИтогНДС;
2)[font=Verdana][/font][font=Verdana][/size][size=78%]Иначе //            возврат поставщику 60.1 (76.1) - 10.х[/size][/font]
Операция.Дебет.Счет = СчПоставщика;
Операция.Дебет.Субконто(1,Получатель);
Операция.Дебет.Субконто(2,Договор);
Если СчПоставщика = СчетПоКоду("62.8") тогда
Операция.Дебет.ВидыРеализацииМатериалов = ВидРеализации;
КонецЕсли;
Операция.Сумма= СуммаСНДС - НДС;
Операция.СодержаниеПроводки = "Возврат поставщику";
Если (АвтоКП=1) Тогда
ТаблицаПокупок.НоваяСтрока();
ТаблицаПокупок.Товар = Материал;
ТаблицаПокупок.Всего = СуммаСНДС;
ТаблицаПокупок.Сумма = Сумма;
ТаблицаПокупок.НДС   = НДС;
КонецЕсли;





Последний раз редактировалось: MuI_I_Ika; 13 Фев 2014, 17:55


Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Что-то у нас вообще  в этом модуле чушь написана (кто-то его писал задолго до моего прихода).Сейчас поменяли новый  план счетов, в нем открыли субсчета к сч. 60 и 62 для каждой из служб, в этом и загвоздка. В общем мне его надо переписать. Может, кто-нибудь уже поделиться готовым модулем документа "Отгрузка материалов на сторону", А я подкорректирую под себя. Спасибо.

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
выбрать счет который является элементом группы 62.0

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
А откуда может браться СчПоставщика?

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
А откуда может браться СчПоставщика?

из плана счетов.
у всех разная аналитика, посмотрите какой у вас счет стоит для основных расчетов с поставщиками.
думаю что у вас 62.1.

чему равен СчПоставщика до вашего фрагмента кода?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 116
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal