Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 16:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программно создать ДеревоЗначений  (Прочитано 1600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Подскажите пожалуйста как создать на обычной форме Табличное поле Тип - ДеревоЗначений ПРОГРАММНО.

Обхожу дерево и по количеству веток первого уровня создаю вкладки.
Для каждого Строка0 из ДеревоФайл.Строки Цикл     /
Для каждого Строка1 из Строка0.Строки Цикл
                                ЭлементыФормы.Панель.Страницы.Добавить(Строка1.Сущность,Строка1.Сущность);
                Для каждого Строка2 из Строка1.Строки Цикл
                                         ??? ветки нижнего уровня отобразить как дерево на созданной вкладке
         конецЦикла;
                       КонецЦикла;
КонецЦикла;


Оффлайн belu

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2014-02-07
  • Сайт: 
Привет!
как создать на обычной форме Табличное поле Тип - ДеревоЗначений ПРОГРАММНО

Создать программно можно так:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   //Создаем табличное поле
   //Панель1 уже создана на форме
   ТабПоле = ЭлементыФормы.Добавить(тип("ТабличноеПоле"),"ИмяТабПоля",Истина,ЭлементыФормы.Панель1);
    //Ставим тип поля Дерево значиний   
   ТабПоле.ТипЗначения = Новый ОписаниеТипов("ДеревоЗначений");
   //Устанавливаем размеры
   ТабПоле.Верх=10;
    ТабПоле.Ширина=ЭтаФорма.Ширина;
    ТабПоле.Высота=ЭтаФорма.Высота-1;
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 687
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal