Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программно создать ДеревоЗначений  (Прочитано 1379 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ученик_2014

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Подскажите пожалуйста как создать на обычной форме Табличное поле Тип - ДеревоЗначений ПРОГРАММНО.

Обхожу дерево и по количеству веток первого уровня создаю вкладки.
Для каждого Строка0 из ДеревоФайл.Строки Цикл     /
Для каждого Строка1 из Строка0.Строки Цикл
                                ЭлементыФормы.Панель.Страницы.Добавить(Строка1.Сущность,Строка1.Сущность);
                Для каждого Строка2 из Строка1.Строки Цикл
                                         ??? ветки нижнего уровня отобразить как дерево на созданной вкладке
         конецЦикла;
                       КонецЦикла;
КонецЦикла;


Оффлайн belu

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2014-02-07
  • Сайт: 
Привет!
как создать на обычной форме Табличное поле Тип - ДеревоЗначений ПРОГРАММНО

Создать программно можно так:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   //Создаем табличное поле
   //Панель1 уже создана на форме
   ТабПоле = ЭлементыФормы.Добавить(тип("ТабличноеПоле"),"ИмяТабПоля",Истина,ЭлементыФормы.Панель1);
    //Ставим тип поля Дерево значиний   
   ТабПоле.ТипЗначения = Новый ОписаниеТипов("ДеревоЗначений");
   //Устанавливаем размеры
   ТабПоле.Верх=10;
    ТабПоле.Ширина=ЭтаФорма.Ширина;
    ТабПоле.Высота=ЭтаФорма.Высота-1;
КонецПроцедуры


Теги:
 

Создать com соединение [com соединение]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 481
Последний ответ 30 Май 2017, 16:52
от MuI_I_Ika
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3179
Последний ответ 21 Мар 2015, 20:24
от дфтын
Программно открыть отчет скд и отчет подключенный как внешний отчет

Автор 1ckaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3932
Последний ответ 02 Фев 2015, 10:06
от 1cka
Создать базу с новым списком баз или как скрыть базу

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 11
Просмотров: 6905
Последний ответ 04 Дек 2012, 13:47
от Gendelf
Как в Native API 8.2 в методе класса создать экземпляр другого класса?

Автор qesrf3we4rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2658
Последний ответ 01 Апр 2011, 11:03
от qesrf3we4r

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 845
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal