Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 15:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обеспечение возможности ручной корректировки в самописном документе  (Прочитано 1648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lighthead9288

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
Доброго времени суток, уважаемые эксперты. Стоит задача: обеспечить возможность ручной корректировки проводок созданного документа ПриходТовара(имеющего соответствующий реквизит РучнаяКорректировка).
Для этого на кнопку ДтКт на форме документа подцеплена стандартная обработка КорректировкаДвижений.

Содержание модуля объекта следующее:
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// ПОДГОТОВКА ПРОВЕДЕНИЯ ПО ДАННЫМ ДОКУМЕНТА
ПроведениеСервер.ПодготовитьНаборыЗаписейКПроведению(ЭтотОбъект);
Если РучнаяКорректировка Тогда             
Возврат;
КонецЕсли;

 
// регистр ПРОБА_движения_товаров Приход
Движения.ПРОБА_движения_товаров.Записывать = Истина;
Для Каждого ТекСтрокаПриходТовара Из ПриходТовара Цикл
Движение = Движения.ПРОБА_движения_товаров.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Дата = Дата;
Движение.Партия = Ссылка;
Движение.Товар = ТекСтрокаПриходТовара.Товар;
Движение.Склад = Склад;
Движение.Организация = Организация;
Движение.Количество = ТекСтрокаПриходТовара.Количество;
Движение.Стоимость = ТекСтрокаПриходТовара.Сумма;
КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
                                 

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
       
Если ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

ДополнительныеСвойства.Вставить("ЭтоНовый", ЭтоНовый());

// Посчитать суммы документа и записать ее в соответствующий реквизит шапки для показа в журналах
//СуммаДокумента = Товары.Итог("Сумма");

КонецПроцедуры



Запустил отладку, установил флажок "Корректировка движений", попробовал провести - вылезла ошибка
"Данные были изменены или удалены другим пользователем".
Решил данную проблему обновлением формы документа:
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
ЭтаФорма.Прочитать();

КонецПроцедуры


Всё чудесно проводится,но появилась новая проблема - при изменении значений табличной части или реквизитов формы и последующем проведении сохраняются старые значения.(К примеру, был приход на Склад1 5 единиц Товара1;  изменяешь 5 единиц на 4 - всё равно остаётся 5).
Очевидно, что это связано с этим:
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
ЭтаФорма.Прочитать();

КонецПроцедуры


Возникает вопрос: как правильно обновить форму? В правильном ли месте(на клиенте) я это делаю?
Заранее спасибо.

Последний раз редактировалось: MuI_I_Ika; 11 Фев 2014, 10:55


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3601
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 336
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3768
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2049
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 926
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 275
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal