Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 16:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УПП 1.3, видимость в форме выбора. Помогите новичку пожалуйста.  (Прочитано 2519 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СеменСергеевич

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-10
  • Сайт: 
  • Профессия: Программист 1С
Всем привет!
Такая задачка: в справочнике "ДоговорыКонтрагентов" есть реквизит срок действия. Нужно, чтобы в документах УПП, когда выбираешь договор в этом документе, не показывать те договоры, которые имеют срок действия меньше даты документа.

Прошёлся по коду отладчиком, не найду, куда именно выводятся данные, которые затем видит пользователь (тот или иной договор).


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Тебе нужно передавать  параметр Даты документа в ФормуВыбора Договоров. Но это имеет смысл, если документ записан - иначе откуда будет браться дата.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн СеменСергеевич

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-10
  • Сайт: 
  • Профессия: Программист 1С
Тебе нужно передавать  параметр Даты документа в ФормуВыбора Договоров. Но это имеет смысл, если документ записан - иначе откуда будет браться дата.

Ну да, дата будет только при записи документа. Но вот куда передавать параметр не пойму. Кода немного в модуле формы выбора, пробежался отладчиком по всем вызываемым функциям и процедурам... но ничего не заметил...

Процедура ПриОткрытии()

Если РежимВыбора И НЕ ЗначениеЗаполнено(Отбор.Владелец.Значение) Тогда
ФормаВыбораВладельца = Справочники.Контрагенты.ПолучитьФормуВыбора();
ФормаВыбораВладельца.Заголовок = "Выберите контрагента, договор которого Вы хотите выбрать.";
Контрагент = ФормаВыбораВладельца.ОткрытьМодально();
Если ТипЗнч(Контрагент) = ТипЗнч(Отбор.Владелец.Значение) Тогда
Отбор.Владелец.Значение = Контрагент;
КонецЕсли;
Отбор.Владелец.Использование = ЗначениеЗаполнено(Отбор.Владелец.Значение);
КонецЕсли;

Если Отбор.Владелец.Использование И Отбор.Владелец.ВидСравнения = ВидСравнения.Равно Тогда
ЭлементыФормы.СправочникСписок.Колонки.Владелец.Видимость = Ложь;
КонецЕсли;

РаботаСДиалогами.УстановитьВидимостьПроекта(, ЭлементыФормы, "СправочникСписок.ОсновнойПроект");

МеханизмНумерацииОбъектов.ДобавитьВМенюДействияКнопкуРедактированияКода(ЭлементыФормы.ДействияФормы.Кнопки.Подменю);
МеханизмНумерацииОбъектов.УстановитьДоступностьПоляВводаНомера(Метаданные.Справочники.ДоговорыКонтрагентов, ЭлементыФормы.СправочникСписок, ЭлементыФормы.ДействияФормы.Кнопки.Подменю, ЭлементыФормы.СправочникСписок.Колонки.Код);
КонецПроцедуры


Добавлено: 11 Фев 2014, 21:45

Всем спасибо за безумно активную помощь =D Кому интересно:

Процедура НачалоВыбораЗначенияДоговораКонтрагента, там прописываем что-то типа отбора

ФормаВыбора.СправочникСписок.Отбор.СрокДействия.ВидСравнения = ВидСравнения.Больше;
ФормаВыбора.СправочникСписок.Отбор.СрокДействия.Использование = Истина;
ФормаВыбора.СправочникСписок.Отбор.СрокДействия.Значение = ДокументОбъект.Дата;


Документ создаётся изначально с датой сегодняшней, поэтому всё норм, видно только непросроченные договоры.

Последний раз редактировалось: СеменСергеевич; 11 Фев 2014, 21:45. Причина: Объединение сообщений


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4685
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5955
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6284
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5105
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2221
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
30 Сообщений

* Кто онлайн

  • Точка Гостей: 248
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal