Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как заполнить динамически добавленную колонку  (Прочитано 2962 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ОльгаЕ

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте. Очень нужна помощь.
Есть обработка. У обработки табличное поле. ТипЗначения = ВнешняяОбработка.ТабличнаяЧасть...
В это табличное поле по мере необходимости нужно добавлять колонки, которые должны иметь положение "на следующей строке" уже написан код, который выдает


А теперь вопрос: как заполнить колонки "номенклатура9", "номенклатура10" и т.д., которые были добавлены динамически, т.е. на момент описания реквизитов обработки их нет?
Код:

      
Для каждого ТекущаяСтрока Из Результат Цикл

Если ТекущаяСтрока.ДатаДоставки <> ДатаСт Или ТекущаяСтрока.Автомобиль <> АвтомобильСт ИЛИ ТекущаяСтрока.Объект <> ОбъектСт ИЛИ
ТекущаяСтрока.Заказчик <> ЗаказчикСТ ИЛИ ТекущаяСтрока.ДатаЗаказа <> ДатаЗаказаСТ Тогда

НоваяСтрока = СписокЗаказов.Добавить();
НоваяСтрока.ДатаЗаказа = ТекущаяСтрока.ДатаЗаказа;
НоваяСтрока.ДатаДоставки = ТекущаяСтрока.ДатаДоставки;
НоваяСтрока.НомерЗаказа = ТекущаяСтрока.НомерЗаказа;
НоваяСтрока.Заказчик = ТекущаяСтрока.Заказчик;
НоваяСтрока.Объект = ТекущаяСтрока.Объект;
НоваяСтрока.Автомобиль = ТекущаяСтрока.Автомобиль;
НоваяСтрока.Водитель = ТекущаяСтрока.Водитель;
НоваяСтрока.Номенклатура = ТекущаяСтрока.Номенклатура;
//НоваяСтрока.Количество = ТекущаяСтрока.Количество;
ДатаСТ = ТекущаяСтрока.ДатаДоставки;
АвтомобильСТ = ТекущаяСтрока.Автомобиль;
ЗаказчикСТ = ТекущаяСтрока.Заказчик;
ВодительСТ = ТекущаяСтрока.Водитель;
ОбъектСТ = ТекущаяСтрока.Объект;
ДатаЗаказаСТ = ТекущаяСтрока.ДатаЗаказа;
n = 9;
Иначе

ИмяНовойКолонки = "Номенклатура"+n;
Если ЭлементыФормы.СписокЗаказов.Колонки.Количество() = n Тогда

НоваяКолонка = ЭлементыФормы.СписокЗаказов.Колонки.Вставить(n,ИмяНовойКолонки);
НоваяКолонка.Положение = ПоложениеКолонки.НаСледующейСтроке;
НоваяКолонка.УстановитьЭлементУправления(Тип("ПолеВвода"));
ИмяКолонки = НоваяКолонка.Имя;


КонецЕсли;


n = n+1;
КонецЕсли;
КонецЦикла
      

Последний раз редактировалось: MuI_I_Ika; 07 Фев 2014, 18:04


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Нужно хранить количество добавленных динамических колонок и обращаться к ним через скобки [] по имени

Оффлайн ОльгаЕ

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Консультант 1С
Если Вам, не очень сложно, можно конкретно написать какой должен быть код. И я вот все сижу соображаю: у меня в данных у табличного поля стоит табличная часть, а может быть лучше таблица значений?
Добавлено: 07 Фев 2014, 20:18

Переписала. Сделала через таблицу значений. Табличное поле тоже заполняется после метода СоздатьКолонки(). НО мне надо, что бы положение колонок было "на следущей строчке", После метода СоздатьКолонки пишу ЭлементыФормы.СписокЗакзовТЧ.Колонки... и вот тут то и засада - она хочет конкретное имя колонки, а переменную не воспринимает. Умоляю помогите :wacko:
Добавлено: 07 Фев 2014, 21:04

Всем спасибо. Все получилось. Через ТЗ. Если кому интересно - обращайтесь в личку.

Последний раз редактировалось: ОльгаЕ; 07 Фев 2014, 21:04. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 252
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal