Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Re: Помогите новичку освоить восьмерку в конфигурировании  (Прочитано 1843 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andryus

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-03
  • Сайт: 
  • Профессия: Программист 7.7
Не буду открывать новую тему для своего вопроса, т.к. вопрос так же касается "конфигурирование для новичка". Суть вопроса заключается вот в чем, для обучения, ради эксперимента создаю простенькую конфигурацию. Чтобы разобраться что и как работает в восьмерке, часть идей "беру" с типовых конфигураций, чтобы покрутить эти моменты на своей конфигурации и просто напросто зачем изобретать велосипед если он давно уже изобретен. Значит суть состоит в следующем. Создан справочник Организации (создан, не скопирован). Скопирован из типовой Регистр сведений ОтветственныеЛицаУчреждений. Взят от из типовой, но единственное что я заменил, что Ресурс ОтветственноеЛицо ссылался на справочник Сотрудники, а мне это не нужно и я сделал этот Ресурс по типу Строка длинной 150 символов. Значит этот Регистр имеет: Измерения: Учреждения (ссылка Справочник.Организации), ВидОтветственногоЛица (Перечисление); Ресурс: ОтветственноеЛицо (Строка,150). Далее в справочнике Организации в ФормеЭлемента создаю Табличное поле: ТПОтветственныеЛица с типом значения РегистрСведенийСписок.ОтветственныеЛицаУчреждений. Так же тут создаю поле ввода ДатаПросмотра (Дата). Значит суть этого всего чтобы в выше сказанном табличном поле выводились актуальные да ДатаПросмотра ответственные лица. Взял опять же с типовой код, который поставил в Модуль объекта
Процедура ПрочитатьНаборЗаписейОЛ(ТекОбъект, ДатаПросмотра, ТПОтветственныеЛица) Экспорт
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОбъектСсылка", ТекОбъект);
Запрос.УстановитьПараметр("ДатаПросмотра", ДатаПросмотра);

Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               | МАКСИМУМ(ВложенныйЗапрос.Период) КАК Период,
               | ВложенныйЗапрос.ВидОЛ КАК ВидОтветственногоЛица,
               | МАКСИМУМ(ВложенныйЗапрос.Сотрудник) КАК ОтветственноеЛицо
               |ИЗ
               | (ВЫБРАТЬ
               | NULL КАК Период,
               | ОтветственныеЛицаОрганизаций.Ссылка КАК ВидОЛ,
               | NULL КАК Сотрудник
               | ИЗ
               | Перечисление.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
               |
               | ОБЪЕДИНИТЬ ВСЕ
               |
               | ВЫБРАТЬ
               | ОтветственныеЛицаУчрежденийСрезПоследних.Период,
               | ОтветственныеЛицаУчрежденийСрезПоследних.ВидОтветственногоЛица,
               | ОтветственныеЛицаУчрежденийСрезПоследних.ОтветственноеЛицо
               | ИЗ
               | РегистрСведений.ОтветственныеЛицаУчреждений.СрезПоследних(&ДатаПросмотра, Учреждение = &ОбъектСсылка) КАК ОтветственныеЛицаУчрежденийСрезПоследних) КАК ВложенныйЗапрос
               |
               |СГРУППИРОВАТЬ ПО
               | ВложенныйЗапрос.ВидОЛ";

   
ТаблицаНабораЗаписей = Запрос.Выполнить().Выгрузить();
Для каждого СтрокаЗаписи из ТаблицаНабораЗаписей Цикл
Если НЕ ЗначениеЗаполнено(СтрокаЗаписи.Период) Тогда
СтрокаЗаписи.Период = ДатаПросмотра;
КонецЕсли;
КонецЦикла;

ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей);
КонецПроцедуры

Вот данный код ругается на строке
ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей)
Цитировать
{Справочник.Организации.МодульОбъекта(38)}: Метод объекта не обнаружен (Загрузить)
ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей);

Исходя из этого, я так понимаю, что результат запроса он не может загрузить в Табличное поле: ТПОтветственныеЛица, но вот из-за чего не могу понять. Неужели из-за замены типа в Регистре сведений Ресурса ОтветственноеЛицо (что в типовой он был Справочник.Сотрудники, а тут стал Строка). Помогите разобраться


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
В табличном поле нельзя хранить данные (собственно как и загрузить) - это элемент отображения данных.А вот самми данные можешь выгрузить в реквизит формы с типом например таблица значений

Оффлайн andryus

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-03
  • Сайт: 
  • Профессия: Программист 7.7
В табличном поле нельзя хранить данные (собственно как и загрузить) - это элемент отображения данных.А вот самми данные можешь выгрузить в реквизит формы с типом например таблица значений

Это все что выше написано взято с типовой конфигурации. У них же это все работает

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Не буду открывать новую тему для своего вопроса, т.к. вопрос так же касается "конфигурирование для новичка". Суть вопроса заключается вот в чем, для обучения, ради эксперимента создаю простенькую конфигурацию. Чтобы разобраться что и как работает в восьмерке, часть идей "беру" с типовых конфигураций, чтобы покрутить эти моменты на своей конфигурации и просто напросто зачем изобретать велосипед если он давно уже изобретен. Значит суть состоит в следующем. Создан справочник Организации (создан, не скопирован). Скопирован из типовой Регистр сведений ОтветственныеЛицаУчреждений. Взят от из типовой, но единственное что я заменил, что Ресурс ОтветственноеЛицо ссылался на справочник Сотрудники, а мне это не нужно и я сделал этот Ресурс по типу Строка длинной 150 символов. Значит этот Регистр имеет: Измерения: Учреждения (ссылка Справочник.Организации), ВидОтветственногоЛица (Перечисление); Ресурс: ОтветственноеЛицо (Строка,150). Далее в справочнике Организации в ФормеЭлемента создаю Табличное поле: ТПОтветственныеЛица с типом значения РегистрСведенийСписок.ОтветственныеЛицаУчреждений. Так же тут создаю поле ввода ДатаПросмотра (Дата). Значит суть этого всего чтобы в выше сказанном табличном поле выводились актуальные да ДатаПросмотра ответственные лица. Взял опять же с типовой код, который поставил в Модуль объекта
Процедура ПрочитатьНаборЗаписейОЛ(ТекОбъект, ДатаПросмотра, ТПОтветственныеЛица) Экспорт
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОбъектСсылка", ТекОбъект);
Запрос.УстановитьПараметр("ДатаПросмотра", ДатаПросмотра);

Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               | МАКСИМУМ(ВложенныйЗапрос.Период) КАК Период,
               | ВложенныйЗапрос.ВидОЛ КАК ВидОтветственногоЛица,
               | МАКСИМУМ(ВложенныйЗапрос.Сотрудник) КАК ОтветственноеЛицо
               |ИЗ
               | (ВЫБРАТЬ
               | NULL КАК Период,
               | ОтветственныеЛицаОрганизаций.Ссылка КАК ВидОЛ,
               | NULL КАК Сотрудник
               | ИЗ
               | Перечисление.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
               |
               | ОБЪЕДИНИТЬ ВСЕ
               |
               | ВЫБРАТЬ
               | ОтветственныеЛицаУчрежденийСрезПоследних.Период,
               | ОтветственныеЛицаУчрежденийСрезПоследних.ВидОтветственногоЛица,
               | ОтветственныеЛицаУчрежденийСрезПоследних.ОтветственноеЛицо
               | ИЗ
               | РегистрСведений.ОтветственныеЛицаУчреждений.СрезПоследних(&ДатаПросмотра, Учреждение = &ОбъектСсылка) КАК ОтветственныеЛицаУчрежденийСрезПоследних) КАК ВложенныйЗапрос
               |
               |СГРУППИРОВАТЬ ПО
               | ВложенныйЗапрос.ВидОЛ";

   
ТаблицаНабораЗаписей = Запрос.Выполнить().Выгрузить();
Для каждого СтрокаЗаписи из ТаблицаНабораЗаписей Цикл
Если НЕ ЗначениеЗаполнено(СтрокаЗаписи.Период) Тогда
СтрокаЗаписи.Период = ДатаПросмотра;
КонецЕсли;
КонецЦикла;

ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей);
КонецПроцедуры

Вот данный код ругается на строке
ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей)
Цитировать
{Справочник.Организации.МодульОбъекта(38)}: Метод объекта не обнаружен (Загрузить)
ТПОтветственныеЛица.Загрузить(ТаблицаНабораЗаписей);

Исходя из этого, я так понимаю, что результат запроса он не может загрузить в Табличное поле: ТПОтветственныеЛица, но вот из-за чего не могу понять. Неужели из-за замены типа в Регистре сведений Ресурса ОтветственноеЛицо (что в типовой он был Справочник.Сотрудники, а тут стал Строка). Помогите разобраться

ТПОтветственныеЛица не тот имеет тип, советую для начала руками заполнять, перебирая по строчно, затем уже пользоваться выгрузками / загрузками.

Все методы написаны в синтаксис помощнике.

Оффлайн Alekssf

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-07
  • Сайт: 
Добрый день.
Во-первых. Это код для управляемого режима или для обычного.
Во-вторых. Этот кусок кода бессмыслен. Периодический регистр сведений не позволить сделать запись без указания Периода. Поэтому это поле в регистре не может быть не заполненным. И даже если это нужно, то правильнее это сделать сразу в запросе.
	Для каждого СтрокаЗаписи из ТаблицаНабораЗаписей Цикл
Если НЕ ЗначениеЗаполнено(СтрокаЗаписи.Период) Тогда
СтрокаЗаписи.Период = ДатаПросмотра;
КонецЕсли;
КонецЦикла;

В-третьих. Платформа вам явно подсказала, что для вашего объекта метода Загрузить нет. Значит нужно выбрать другой объект или изменить алгоритм заполнения.



Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4294
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4374
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal